It's all about the answers!

Ask a question

ajax Framework does not work with dojo 1.8 - how to upgrade dojo version?


Jun Jing Zhang (111) | asked Jul 20 '13, 5:26 a.m.
Is there official document to upgrade dojo version within ajax Framework? I replace all dojo resources in org.dojotoolkit.dojo_1.6.1.v20130106_1027.jar, and get the below error: 

[7/20/13 17:19:49:805 CST] 0000014d AjaxFramework E net.jazz.ajax.internal.util.TraceSupport error dojo._base.url: No matching dojo.provide found


Comments
Millard Ellingsworth commented Jul 24 '13, 4:04 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Hi, Jun. I don't quite follow your question. Are you trying to change the version of dojo used by the Rational Team Concert product? I understand that we are working on dojo 1.8 support for a future release and I'm reasonably certain you cannot change this yourself.


Jun Jing Zhang commented Jul 26 '13, 1:31 a.m.

 Millard, yes, I'm trying to change the dojo version by myself. 

  • What's the latest dojo version we support in official build?¬†
  • when you say you are working on dojo 1.8 support, it means 4.0.4M2?

One answer



permanent link
Millard Ellingsworth (2.5k12431) | answered Jul 26 '13, 1:23 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
I don't want to make any "forward looking statements", but this work item indicates that dojo 1.8 adoption is complete (for at least some components, so I expect it's safe to assume successful adoption by others). When exactly it will be released I can't say for certain, but it seems to be targeted for 4.0.4 at this time.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.