It's all about the answers!

Ask a question

OSLC return 0 elements for dc:type "epic" and "story" but works for tasks

srikar sana (11) | asked Aug 24 '20, 11:08 p.m.

hi people,
My requirement :

i would like to prepare a URL which can query for epic workitems owned by particular person that is planned for previous iteration (not the current one).
URL which i created after some reading :
?oslc_cm.query=rtc_cm:plannedFor="SOME_ITERATION" and rtc_cm:ownedBy="SOME_PERSON" and dc:type="epic"
Assume that SOME_ITERATION and SOME_PERSON is working fine as it is working for the dc:type = "task"

when i create the same query using gui it shows there are epics but when i use this it doesnt throw an error but it returns me 0.
i am not able to figure out the problem here.

could some one please help me on how to identify the problem.

things i have tried:
i have tried using the full type from the workitem xml and there was no use
some where in this forum i saw dc:type defect where it is told to use rtc_cm:type and that was also in vain.
i then check OSLC version and it was 1.0 for us. read it in the xml output. and i am not sure of whether i saw it properly or not. could some also tell me how to enquire oslc version from the server itself.

and thanks in advance for solving my problem
thank you so much.

Be the first one to answer this question!

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.