It's all about the answers!

Ask a question

How to update the parameters list in query used in widget

Pascal Jean (6012340) | asked Jul 15 '13, 5:15 a.m.
I'm using CLM (RTC) 4.0.1.
I'm creating a widget and associate it to a query. The query is built on a record type we created.
From the list of parameters I would like to pick-up a date (for that example a "Creation Date"). The "Creation Date" is a field of the record type.
I don't find any dates within the list. Questions:
  • How is built the list of  parameters on widget.
  • Is it possible to change the list of parameter, is it possible to add dates in the parameters list.
Thank you in advance
Pascal Jean

Clement Liu commented Jul 15 '13, 5:18 p.m.

Hi @pascaljean,

Is this the "Work Items" widget you were talking about?  Can you help me understand how you wanted to build the list of parameters on the widget?  Thank you.

Accepted answer

permanent link
Clement Liu (1.5k54249) | answered Jul 17 '13, 11:28 a.m.
 Hi Pascal,

This is what I found out. The Work Item Statistics viewlet is restricted to properties of the "enumeration" type. This is the link to the original post:

You can put in a enhancement if you feel like you have a valid use case.

Hope it helps. Thanks. 
Pascal Jean selected this answer as the correct answer

2 other answers

permanent link
Pascal Jean (6012340) | answered Jul 16 '13, 3:31 a.m.

Hello @Clement,

Here is the list of parameters available when we update the widget settings.

To my understanding, we should see the "Creation Date" between the "Created By" and "Custom 10_WR" fields (cont...)

This is the case when building "regular" queries. The same query used in the widget.

When creating a query, the field "Creation Date" can be added in the Column Display.

permanent link
Pascal Jean (6012340) | answered Jul 18 '13, 2:42 a.m.

Hello Clement,
This sounds good. I think it corresponds to issue I have. At least it is very close.
I'll open a RFE if it doesn't exist yet.
Thank you again.
Pascal Jean

Your answer

Register or to post your answer.