It's all about the answers!

Ask a question

SVN importer does not honor SVN EOL properties


David Ward (8311114) | asked Jul 08 '13, 8:16 a.m.
Using RTC 4.0.0.2

I attempting to import the trunk of my SVN repository (and its tags) into an RTC component.  After the import completes I loaded of the resulting component and did a full folder compare to see if RTC is returning the same files as SVN would.  

I'm using a Windows machine.
On the SVN side all our source files (.c .h .cpp .hpp and others) have EOL:native properties set,

It appears that for RTC, some of the loaded files come out with Unix EOL .. making me think that the importer has ignored the SVN EOL properties.  

Does the the RTC importer respect SVN EOL properties ?

I know I can add a changeset to set the file properties for RTC, but that only works for the head of the component, not the embedded baselines (derived from the SVN tags).

Any help appreciated
Dave

One answer



permanent link
Tim Mok (6.6k38) | answered Jul 08 '13, 9:50 a.m.
JAZZ DEVELOPER
The svn:eol-style property is respected. Can you check if the jazz file property has the line delimiter is set to platform? If it isn't set to that, it might be a bug in the SVN importer. If it's set, it might be something wrong with the content loading.

Comments
David Ward commented Jul 08 '13, 1:43 p.m. | edited Jul 08 '13, 1:57 p.m.

I hand-checked a few files in the SVN repo and they all had svn:eol-style=native set.  Those same files ended up in RTC with "Line Delimiter" set to "Binary".  


Looking further .... Its hard to be sure, but it appears that all (a lot ?) of the SVN files with eol-style=native ended up as binary files within RTC.

Perhaps there's an option that I didn't check during the import ?


Tim Mok commented Jul 08 '13, 1:59 p.m.
JAZZ DEVELOPER

You'll have to open a defect. Something doesn't seem right with the import setting the line delimiter. If you have a simple SVN dump that shows the issue, please include it in the defect.


David Ward commented Jul 08 '13, 2:00 p.m. | edited Jul 08 '13, 2:13 p.m.

Here's another data-point


If I load one of the baselines (instead of just loading the latest state of the component), at least one of the files that previously was binary, is now correctly set with a delimiter of "platform".

Very confusing


Tim Mok commented Jul 08 '13, 2:15 p.m. | edited Jul 08 '13, 2:15 p.m.
JAZZ DEVELOPER

Your best option is to file a defect. This doesn't seem like normal behaviour and I don't think any options during the import will give you the correct result.

FYI, you can respond to an answer instead of creating a new answer if you're only providing information about the problem and not really providing a solution. I'm converting your answers to comments.


David Ward commented Jul 09 '13, 10:19 a.m.

 OK I'll open a defect.  The SVN dump isn't small I'm afraid but I'll with who-ever is working the defect to help recreate.

Your answer


Register or to post your answer.