It's all about the answers!

Ask a question

Issue with running rhevm-shell from build definition


Dhanunjaya L (133) | asked May 18 '13, 7:40 a.m.
edited May 20 '13, 3:50 p.m. by Millard Ellingsworth (2.5k12431)
When I run rhevm-shell (command line tool to redhat enterprise enterprise virtual manager) from RTC build definition (command line -Jazz build engine) I get following error.

Traceback (most recent call last):
  File "/usr/bin/rhevm-shell", line 9, in <module>
    load_entry_point('rhevm-shell==3.1.1.2-SNAPSHOT', 'console_scripts', 'rhevm-shell')()
  File "/usr/lib/python2.6/site-packages/ovirtcli/main.py", line 27, in main
    context = OvirtCliExecutionContext(sys.argv, parser)
  File "/usr/lib/python2.6/site-packages/ovirtcli/context.py", line 45, in __init__
    super(OvirtCliExecutionContext, self).__init__(args=args, option_parser=option_parser)
  File "/usr/lib/python2.6/site-packages/cli/context.py", line 69, in __init__
    self.terminal = create(self.Terminal)
  File "/usr/lib/python2.6/site-packages/cli/object.py", line 26, in create
    obj = cls(sys.stdin, sys.stdout, sys.stderr, **kwargs)
  File "/usr/lib/python2.6/site-packages/cli/platform/posix/terminal.py", line 36, in __init__
    self._tty = os.open('/dev/tty', os.O_RDWR)
OSError: [Errno 6] No such device or address: '/dev/tty'

Any idea how to fix this issue ?
I am using RTC 3.0.1.1

When I run the same from command prompt it works fine.

One answer



permanent link
Ralph Schoon (60.7k33643) | answered May 22 '13, 7:40 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I don't think this is related to RTC, I think this is related to something in your environment or OS. I don't know the particular tools, but that it complains that there is no device /dev/tty, tells me you should probably use a different device or device name. This might or might not be related to environment settings not available if you run in the JBE, which even might be running on a different machine. You could e.g. try to dump the environment in the build. Maybe you inherit /dev/tty from your user login settings and JBE does not?

Your answer


Register or to post your answer.