It's all about the answers!

Ask a question

Rational Team Concert Project Activity Report Empty


Enrico Savini (15911) | asked May 17 '13, 3:23 a.m.

Though I checked every stream in our Project Area, in the default "Project activity" report is always empty. SCM job runs fine. We don't use agile (template in formal) and we're always on the same timeline (Maintenance). These settings can affect results?

My environment: RTC 4.0.0.1 (updated from 3.0.1)

DB: DB2

Datawarehouse: YES

Application Server: WAS 7

Thanks in advance.

Enrico


Comments
Krzysztof Ka┼║mierczyk commented May 17 '13, 3:36 a.m.

Hello Enrico,
Could you look into <your-server>/logs/ccm.log file? Do you have any errors there?


Enrico Savini commented May 17 '13, 4:00 a.m.

Thanks Krzystof,

no evidence in ccm.log....

The only message is just where the repot should appear: "no SCM data found".

Enrico

Accepted answer


permanent link
Indradri Basu (1.8k1514) | answered May 17 '13, 4:24 a.m.
Hi Enrico, if the DW jobs are running fine and still you can't see any data on the report then there is a possibility that the etl_user is not a member of the concerned project area.

If the above is true, add the etl_user as a member of the project area and run the Full data collection jobs. Also check if the etl_user has been granted a CCM data collector license.
Enrico Savini selected this answer as the correct answer

Comments
Enrico Savini commented May 17 '13, 4:45 a.m.

Good point Indradri,

I just added the etl_user to the Project Area. I resubmitted the job but still no data found. Maybe it's normal 'cause the job has just started and I've to wait for a while?

Thanks.

Enrico

One other answer



permanent link
Enrico Savini (15911) | answered May 17 '13, 5:13 a.m.

I'm definitely an idiot. I checked the report parameters and now, magically reports run fine.... sure it was difficult present some date without choosing a stream!!!!!

Now I've to tune the parameters to get useful results.

Thanks

Enrico


Comments
Indradri Basu commented May 17 '13, 5:20 a.m.

Glad it worked but I have a feeling that if the etl_user was not added to the project area before then what you see now is the result of the last run of your data collection jobs.


Enrico Savini commented May 17 '13, 5:24 a.m.

Sure Indradri, thank you very much I'm going to mark your answer as the right one!

Bye.

Enrico

Your answer


Register or to post your answer.