It's all about the answers!

Ask a question

Unable to colorize workitems without tracks links in plan view


Chris Thompson (11268) | asked May 15 '13, 7:03 a.m.
I am trying to create a Plan View which highlights workitems that do not have any "Tracks" links to workitems (in other repositories). I have tried to add a color tag to the Plan View using an expression against the "tracks:" property. I have two issues:

1) None of the options available produce a "correct" result - e.g. using "unset" colorizes all workitems regardless of whether or not they have links

incorrect result of tracks:unset

2) Duplicate "tracks:" entries in expression auto-complete :

duplicate tracks: entries

Comments
Millard Ellingsworth commented May 20 '13, 4:01 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Hi, Chris. What version of RTC are you using? Also, I don't recognize the icon on 2 of those work items -- is this a customized work item type or did you just change the icons? If you have customized it, can you explain the sort of customizations done? The doubled set of choices certainly seems like a defect.


Chris Thompson commented May 21 '13, 6:19 a.m. | edited May 21 '13, 6:20 a.m.

I am using RTC 4.0.2 with the Formal Project Management template, the first item shown is the built in "Business Need" workitem type and the second icon (P) is a custom workitem type with 5 custom attributes and a custom workflow. I can provide you with access to the internal IBM repository if that helps?


Millard Ellingsworth commented May 21 '13, 7:16 p.m. | edited May 21 '13, 7:20 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Using a default Formal template project (though with 4.0.3 RC1 -- I doubt there's much difference), I was able to add a colorization similar to yours (tracks:unset) and all of my items were marked. I then opened an item and added a new work item as a Tracks relationship. When I saved, returned to the plan and refreshed, the item I added the link to no longer had the "No Track" colorizing. 


All of my items are of the default Business Need type. Are you having this issue with that type also, or just with your custom type?

I did notice that you have to use tracksRequirement: if you are tracking to requirements in /rm. tracks: is different (more of a cross-project planning thing than a traceability thing).


Chris Thompson commented May 22 '13, 11:50 a.m.

I have the issue with both the built-in Business Need and the custom Plan Item type.

This repository started life some time ago and so if there have been changes to the process template I guess we will not have picked those up during upgrade?

These are tracks between RTC workitems, I have not tried colorizing for RM tracks


Millard Ellingsworth commented May 22 '13, 12:57 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

As Ralph points out below, my choice of 4.0.3 may be why I did not reproduce your issue. That means that upgrading to 4.0.3 is likely your best path to resolving this.


Process template changes are not automatically handled during upgrades. I don't think this should be a process template issue, though, as the planning code is deciding whether or not to colorize a line based on relationships in the data.

2 answers



permanent link
Ralph Schoon (56.6k23642) | answered May 22 '13, 4:01 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Chris, I just looked into 4.0.1 and I saw the same. I tried with 4.0.3 M4 and that worked. I assume that is a defect.

Comments
Millard Ellingsworth commented May 22 '13, 10:34 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Ralph, did you see both issues resolved in 4.0.3?

Chris, how difficult is it for you to verify that 4.0.3 fixes the issue?


Ralph Schoon commented May 22 '13, 10:54 a.m. | edited May 22 '13, 12:05 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Millard, I had only time to test with tracks relationship to work items. In 4.0.3 M4 I was able to trigger on having a tracks relationship not having one (!tracks:has) and having a certain number (tracks:2). I assume if this is for other link types you'd need to have another keyword than tracks.


Chris Thompson commented May 23 '13, 11:03 a.m.

Thanks for digging into this. I will need to wait until jazzop19 is upgraded to 4.0.3 to verify - do you know if there is a defect raised already for this?


Ralph Schoon commented May 23 '13, 11:07 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I did not check that Chris, sorry.


Millard Ellingsworth commented May 23 '13, 12:33 p.m. | edited May 23 '13, 2:31 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

er, it turns out I already wrote a defect for the duplicated items: https://jazz.net/jazz/resource/itemName/com.ibm.team.workitem.WorkItem/238975

Since it seems the other issue is fixed on 4.0.3, let's wait until we can verify before filiing a defect for the tracks part. I did notice in my testing that !tracks:has provides different results than tracks:unset. The official documentation doesn't show a "has" option (nor does the wiki guide). Not sure where Ralph got that syntax, but let's not use it.


Chris Thompson commented May 24 '13, 5:06 a.m.

OK, that's great, thanks! I'll find out when the upgrade is planned and re-test once I have access to 4.0.3


Chris Thompson commented Jun 12 '13, 6:48 a.m.

4.0.3 is now available on jazzop19. I still have the problem:

tracks:unset - colorizes all items regardless if they have tracks links or not
tracks:has - does not colorize any items


1
Millard Ellingsworth commented Jun 13 '13, 12:22 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

I setup a new Formal template project added several tasks, set a couple of them to track one of the others (Links tab, Add->Tracks) then added the tracks:unset filter to my plan. It worked exactly the way I expected it to.


So the functionality seems to work. Assuming you are creating the Tracks relationship and looking at the right plan, it's unclear to me what might be different.


Chris Thompson commented Jun 25 '13, 6:12 a.m.

Thanks, I guess the main difference is that I have an upgraded version of RTC? What type of Plan are you using? I am using a "Cross Project Plan"


Ralph Schoon commented Jun 25 '13, 6:25 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Chris,

I tested in the Scrum template with normal plans. Please be aware that in cross project plans the items that are traced are only displayed. They are outside of the plan and I think  the expressions can not access their data.


Chris Thompson commented Jul 03 '13, 5:57 a.m.

Ah, that could be it!

Do the "Tracks" links  exist on the workitems in the "home" repository? In which case I would expect the expression to work (no need to get data from the "away" repositories).

I guess they do as the "tracks" links show up on the "links tab" of the "home" workitems regardless of whether or not I am logged in to the "away" repositories?

I think this may be a defect?


Ralph Schoon commented Jul 03 '13, 7:24 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The links on the work items that are located directly in the team area the plan is displaying are local and thus the local end of the tracks link should be accessible.

Feel free to write a defect or enhancement request.


Erik anderson commented Feb 14 '14, 3:41 p.m.

It works for us if the work item tracks something in the same repository.  It doesn't work  if it tracks a work item in a different repository (using friends).  Not sure if that was the case in the original post, so thought I'd share.

showing 5 of 13 show 8 more comments

permanent link
Erik anderson (38315029) | answered Feb 14 '14, 4:13 p.m.
I opened a defect - https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=303272

Your answer


Register or to post your answer.