It's all about the answers!

Ask a question

RRC 4.0.2 upgrade failing


Liviu Ionescu (13223) | asked Apr 24 '13, 1:50 a.m.

Hello,

We have performed on an upgrade for CLM from v. 4.0.1 to 4.0.2. Our current POC environment is running on Windows 2008 Server 64bit, SP1, single instance (JTS/RTC/RRC installed on the same server. We are using DB2 v. 9.7 on Win 2008 Server 64bit server (a different server). Both are physical servers, with 32GB RAM Memory and plenty of disk space.                                                                  

The installation of the 4.0.2 version completed successfully. We have also successfully completed the execution of the scripts designated to copy the content from the 4.0.1. version files to the 4.0.2 version files.                               

Upon the restart of the server, we are able to successfully log into JTS and into CCM/RTC without any problems, all content seems to be there.                                                          

When logging into the RM/RRC, we get the message that the server is not available for use, as it is either waiting to be upgraded or a upgrade is currently in progress. We click the "Open the Upgrade Service Panel", start the upgrade process and then encounter an error right away: Error 500: Internal Server Error - Array Index Out of Range - see screenshot below. Any feedback would be much appreciated. Thank you.

  RRC Upgrade error


Comments
Liviu Ionescu commented Apr 26 '13, 1:20 p.m.

Thank you to everyone who posted here. Indeed, we worked with Erica, and resolved the problem as she indicated below. We are back in business and working in the new 4.0.2 version. 

Accepted answer


permanent link
Erica Tran (1.4k6) | answered Apr 26 '13, 8:58 a.m.
JAZZ DEVELOPER
Hello,

I worked with Liviu on this issue.  It turns out that the 4.0.1 to 4.0.2 online migration completed and was successful so running the RM online migration again was not needed.  The reason why users were getting a message stating an upgrade was required is because after the successful migration, the server was restarted at some point.  When this was done the old 4.0.1 service started and connected to the upgraded 4.0.2 repository.  This is why the reason for the message about requiring an upgrade.

Since the migration was successful we believed the DB was in a good state.  We went into the database and opened the APPLICATION_MIGRATION_STATUS table.  The MIGRATION_STATE column was changed from 1 which means requires migration, to 5 which means the migration is done.  If the RM online migration had failed, this solution would not have worked as the repository would have been in a bad state. 

Afterwards, initial validation was done.  Project were visible and we were able to access artifacts.  Now users are validating to make sure all is well.


Liviu Ionescu selected this answer as the correct answer

Comments
Indradri Basu commented Apr 26 '13, 9:11 a.m.

Erica, thanks for sharing.

2 other answers



permanent link
Indradri Basu (1.8k1514) | answered Apr 24 '13, 2:34 a.m.
It looks like the online migration of RM applications is pending.
I just copied the below text from Infocenter on how to complete the online migration for RM application

-----------------------

Procedure

  1. Open your browser and clear the browser cache.
  2. Navigate to the RM web client by specifying the server name and port in the following URL: https://hostname.example.com:port/rm/web/projects/migration. The default port is 9443. The web client detects that a migration is in progress and starts the Migration wizard.
  3. Accept the Rational Requirements Composer - Analyst Client Access license.
  4. Click Open the Upgrade Service Panel and then click Next to start the upgrade.

    During the upgrade, on the migration page, the upgrade status reports which storage area is being processed and when it has started indexing. After the upgrade is complete, the RM application data is reindexed.

    After the reindexing is complete, the application performs validation and consistency checks on the migrated data and provides feedback. The message "The Upgrade is complete" is displayed.

  5. Click Close. You will be redirected to the RM application.
  6. After the server starts, perform a Publish Service Initialize at https://hostname.example.com:9443/application context root/publish/initialize.

-----------------------
You may also want to check the Interactive Upgrade Guide for complete set of upgrade instructions in respect to your topology.

permanent link
Mike Jaworski (1.4k6) | answered Apr 24 '13, 9:35 a.m.
JAZZ DEVELOPER
Liviu,

As Indradri alluded to, there are two steps to the migration process for RRC: offline version upgrade scripts, and online migration. I think you were saying that you encountered this error during the online migration step (Upgrade Service Panel) and were unable to proceed further. If you could post the entry from the RM log file referenced in the error image you posted, then we should be able to further diagnose the source of this "Array index out of range" exception.

When I was working with the last customer who was attempting an upgrade to 4.0.2, we found out that it was necessary to ensure the integrity of their indices before performing the upgrade. However, I think before I suggest completely re-attempting the upgrade, it would be good to diagnose the source of this exception. If you are able to provide the stack trace from the referenced entry in the RM server logs, then we can attempt to diagnose.

Thanks,
Mike Jaworski

Comments
Jeffery Hanson commented Apr 24 '13, 10:40 a.m.
JAZZ DEVELOPER

A little more background on the upgrade:
We ran the online migration step (last Friday) and got to the end successfully. During the next reboot cycle (the following Monday) we found that we had not changed the service from 4.0.1 to 4.0.2 so the server started as 4.0.1. We attempted a few logins until we figured out what we had missed. Now starting as 4.0.2 we couldn't log into RM and running the migration again we now have this error.


Mike Jaworski commented Apr 24 '13, 10:53 a.m.
JAZZ DEVELOPER

Jeffery,


Not sure I completely understand. What steps did you take to "change the service from 4.0.1 to 4.0.2"? Did you perform the online migration before you completed the offline upgrade? If that is the case, I'm afraid you may need to redo the upgrade from the start ... If I'm misunderstanding, could you please provide the step-by-step process of your upgrade scenario? Sorry for the back-and-forth ...


Rosa Naranjo commented Apr 24 '13, 12:22 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

Hello Jeff
I'd like to help but I am also confused like Mike with regards to the 'change the service from 4.0.1 to 4.0.2'? If you completed the online migration successfully, why did you run it again and how exactly did you force it to go again? The only way to go again is to start with a back up of the JTS/RM database repository at the 4.0.1 level.  Otherwise, if the JTS/RM db is already at the 4.0.2 level, there would be no reason to either run the scripts again or do the online migration again.
Also, as asked by Mike, we really need the logs in order to see why the error is being posted.
My suggestion is same as Mike's above: redo the upgrade using the 4.0.1 db backup. Especially since it completed successfully the first time.


Jeffery Hanson commented Apr 26 '13, 10:14 a.m.
JAZZ DEVELOPER

See Erica Trans's answer above. Bottom line: We forgot to setup CLM 4.0.2 to 'start as a service' after our successful upgrade. So when we rebooted it automatically started the old 4.0.1 instance since we had not removed that service entry. Part of our regular upgrade checklist needs to include 'Step 1: Remove old service entry'. The upgrade was really straight forward otherwise and only took us 1.5 hours (taking our time to be diligent) for our single server environment. Thanks for your inputs on this thread and the speed at which you have responded. This Jazz Forum really rocks!


Rosa Naranjo commented Apr 26 '13, 2:31 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

Jeff
Just to confirm, was this a Tomcat install? Meaning, if we add this to the checklist, it only applies to Tomcat installations, correct?

Your answer


Register or to post your answer.