It's all about the answers!

Ask a question

Problems with Advanced Release burndown

Murtuza Daginawala (523) | asked Apr 17 '13, 7:29 a.m.

I have been using the Advanced Release Burndown v4 since quite sometime as it gives very useful information about the current status of the project. It was working fine until the last release of our project. But recently we started with a new release and it has stopped working.
One thing i would like to mention is that we were with jazz 3.0.1 while working on the previous release when the chart was working and now we have upgraded to jazz Not sure if this is the cause of the problem.

I have attached the screenshot of the chart. Do note that i have selected all the query information correctly.

Pls help as this is very urgent

Alanna Zito commented Apr 17 '13, 9:56 a.m.

It looks like the report is not able to find any stories planned for the selected iterations.  Have you created stories for your new release and assigned them to the correct iterations?

Are you running this report with any teams selected as parameters?  If so, try running it with no teams selected, and see what the results are.

Murtuza Daginawala commented Apr 17 '13, 10:26 a.m.

Hi, thanks for your reply.

Yes i have created and sized all the story in the Release Backlog. Even the priorities have been assigned to each of the stories in the backlog.

Yes i am running the report with the correct team selected. Also tried without selecting any teams, but the result is still the same. :(

Accepted answer

permanent link
Alanna Zito (1.3k3) | answered Apr 18 '13, 10:09 a.m.
In case anyone else comes across this - Murtuza and I looked at his server together, and found out that the problem was that his project are was not configured to use the "Story Points" attribute as the complexity:

It seems like this might have gotten changed during their upgrade from 3.0.x to 4.0.x - when we set it back to use the story points, the report generated successfully.
Murtuza Daginawala selected this answer as the correct answer

2 other answers

permanent link
Guido Schneider (3.4k1486115) | answered Apr 17 '13, 8:32 a.m.

Be sure you have only plans of the plan type "Release Burndown" on one of the selected iteration. This becomes the Release Iteration.

As soon as you have plans of type release burndown on multiple selected iterations, the Advanced Burndown is not able to know which iteration is the release and it will fail.

permanent link
Murtuza Daginawala (523) | answered Apr 17 '13, 10:01 a.m.
I have created the release iteration and all its child iterations. The release iteration has a Release Backlog (Project) created for it, and all the iterations have plans of type Sprint Backlog created. While creating each of the iterations i have selected 'A release is scheduled for this iteration' because if i dont do this, then the iteration and the associated plan doesnt show up in the Team Artifiact.
As far as i can tell, everything has been configured the same as how it was configured for our last release. I suspect there is some compatibility problems with Jazz

Correction: This is for the Enhanced Release burndown chart!/wiki/W745ad22107e0_4a87_a66d_177bf80b1e9d/page/Enhanced%20Release%20Burndown%20Chart%20%28RTC%29

Alanna Zito commented Apr 17 '13, 11:08 a.m.

Unfortunately, I'm not very familiar with the Enhanced Release burndown chart, since it's not one that we ship with RTC.  I'm not sure if it needs any updating to work with v4.0.x.  You may want to contact the author of that report for help.  Alternatively, you could try using the out of the box Advanced Release Burndown report instead; but, I'm not sure if it has all the same features.

Guido Schneider commented Apr 17 '13, 11:37 a.m.

I confirm this, the new Advanced Burndown, shipped with RTC (outofthebox) works very well (specially the corrected version shipped with V.4.0.2, which works backwards on V.4.0.1)

Kevin Ramer commented Apr 17 '13, 11:41 a.m.

We have found several gotcha's in this report:

  • Current iteration not found due to "common" identifier (development) of Main Timeline -- Change the identifier using Eclipse RTC. Clue to this would be that under Data of the report Current iteration is Unknown or a sprint NOT in your project area.
  • Boundaries of Release plan should include all other sprints (even to the point of exactly matching the end dates)

Alanna Zito commented Apr 17 '13, 12:58 p.m.

The first gotcha mentioned by Kevin was fixed in 4.0.3 - see Advanced Release Burndown Report is broken (235465).  That work item also has the fixed report design files attached.

Murtuza Daginawala commented Apr 17 '13, 1:07 p.m.

Hi Kevin

Yes i am seeing some probs with the values displayed in the 'Data' twisty. This is what i can see on the report.

Project area: displayed correctly

Team area(s): displayed correctly
Release end date: does not display anything, blank value

Planned release iteration: 2nd last iteration instead of last iteration

Current iteration: does not display anything, blank value, even though the current iteration has been set

I did verify all the dates and the parent iteration end date is the same as the end date of the last iteration.

Any idea what else i can check?

Your answer

Register or to post your answer.