It's all about the answers!

Ask a question

Error when unarchiving user


Leonardo Marzo (24954852) | asked Apr 10 '13, 10:22 a.m.
edited Apr 10 '13, 10:23 a.m.
 Hi,

We archived a user from jts/admin. Then we tried to unarchive him from Eclipse Client. The process finished successfully, however, the user still appears as archived in RQM so he is not able to login to RQM. When I try to unarchive it from RQM, the following error is shown:
Error unarchiving user: The Jazz Team Server rejected the request because it is based on stale data. Additional information from the server: ConflictID CRJAZ1518E

Do you know how to fix this inconsistent state?  I tried archiving the user again and unarchiving him from jts/admin, but we have the same problem.

I would really appreciate your help.

Note: we are running JTS/RTC/RQM 4.0

Thank you,

Comments
Sandy Grewal commented Apr 10 '13, 10:28 a.m.
JAZZ DEVELOPER

@Leonardo What is the error in the jts log when you try to unarchive the user?

Accepted answer


permanent link
Indradri Basu (1.8k1514) | answered Apr 10 '13, 10:51 a.m.
edited Apr 10 '13, 10:53 a.m.
Hi Leonardo,

I just quickly tested this I was able to reproduce the same error. So if I archive the user from jts/admin the appropriate state of the user is not immediately know by the other applications but it works properly when it is done the other way. So when you did that from eclipse client the application context was ccm.
For now, it seems the best way to avoid this inconsistency is to perform archive and unarchive from same application context like jts/admin.

So try unarchiving from the ccm/admin or eclipse client.
Although I am not sure whether the nightly sync user job fixes this issues automatically.
Leonardo Marzo selected this answer as the correct answer

Comments
Leonardo Marzo commented Apr 11 '13, 2:28 p.m. | edited Apr 12 '13, 11:58 a.m.

It seems that the ETLs jobs did the work. The inconsistency is fixed. 

Thank you very much for your help!


Indradri Basu commented Apr 11 '13, 2:34 p.m.

Leonardo, thanks for posting the feedback.


Bo Chulindra commented Apr 12 '13, 10:47 a.m.
JAZZ DEVELOPER

The applications synchronize their contributor data with the JTS every minute or so.

2 other answers



permanent link
Piotr Aniola (3.6k1534) | answered Apr 10 '13, 10:52 a.m.
Please see the following thread for more details:
https://jazz.net/forum/questions/85407/how-to-do-i-fix-jts_user-errors-in-ccm

Since you are running CLM 4.0, I would say the DB may be corrupted. I recommend contacting support or opening a jazz.net defect

permanent link
vasanthakumari hariharan (234) | answered Sep 14 '18, 12:44 a.m.

Hi,


If you cannot restore any users from CCM url, you can switch to jazz admin page(jts/admin) from where you can restore users easily. 

Your answer


Register or to post your answer.