It's all about the answers!

Ask a question

error on starting jazz server

Sri Sreedharan (1111) | asked Mar 21 '13, 12:51 p.m.
 I downloaded the 4.0 RTC. And I want to set up a repository. When I tried starting hte jazz server I got a list of exceptions.
Are there any pre requisites to be installed.
I am on a Win 7 Professional 64 bit system

Krzysztof Kaźmierczyk commented Mar 21 '13, 1:15 p.m. | edited Mar 21 '13, 1:25 p.m.

Hi Sri,
I was able to successfully install RTC (server and client) on my Windows 7.
Could you provide the screen shot of the exceptions or paste them into this thread?
Can you also let me know if you are attempting to install RTC client or RTC server?

Krzysztof Kazmierczyk

Sri Sreedharan commented Mar 21 '13, 1:24 p.m.

 i downloaded the whole RTC collaborative solution from the zip package and have installed the client and server.

I wanted to set up a repository actually from the team concert shell client. I dont know how to set up an external repository so I tried browsing to https://localhost:9443/jazz/ and it didnt work, So I assumed the server had to be started.
If you can tell me how I can get an external repository set up or give me instructions on how my URL should be like, that would help. I want to experiment with the RTC shell.

Sri Sreedharan commented Mar 21 '13, 1:28 p.m.

 I cant paste the whole exception..

        at org.apache.catalina.loader.WebappLoader.startInternal(WebappLoader.ja
va:629)at org.apache.catalina.util.LifecycleBase.start(
Caused by: Failed to create destination directory to copy r
esources at org.apache.catalina.loader.WebappLoader.setRepositories(WebappLoader.
java:940) at org.apache.catalina.loader.WebappLoader.startInternal(WebappLoader.ja
va        ... 14 more Mar 21, 2013 1:00:26 PM org.apache.catalina.startup.HostConfig deployWAR
SEVERE: Error deploying web application archive C:\Program Files\IBM\JazzTeamSer

One answer

permanent link
Ralph Schoon (61.8k33643) | answered Mar 21 '13, 2:23 p.m.
 Two common errors and issues 

1. Install in Program Files. Even logged in as admin provides the server with too few permissions to create files and folders. Use run as Administrator on the server.startup.bat or install somewhere else
2. You need at least 4 GB of memory. More preferred. If you have only 4 close all other applications.

I would think it is probably 1 in this case based on the error message.

Sri Sreedharan commented Mar 21 '13, 4:37 p.m.

I am not sure thats the case. Is the CLM solution compatible with Win 7 Professional 64 bit system ? I think the profile is not supported.

Ralph Schoon commented Mar 22 '13, 2:28 a.m.

Not supported does not mean "does not work". I have working demo setups on my Win7 64 Professional starting with CLM 2.x products up to CLM 4.x. I have never had issues.

Your answer

Register or to post your answer.