It's all about the answers!

Ask a question

How to deploy a Jazz component on the server


Martin Dam Pedersen (1352814) | asked Mar 20 '13, 5:54 a.m.
 I have followed the tutorial "Hello Jazz -- How to write a simple Jazz component" found here https://jazz.net/library/article/118.

Everything works fine in my test setup with a launcher launching a Jetty RTC server from eclipse. 

But how do i deploy/provision the new service on a standalone server installation ?

I have searched the forum but the only questions related to this is more than 5 years old, and I cant make it work. I assume that perhaps something has changed since 2008, and deployment procedure has changed.

What I have done so far, is to create a feature project for both the service and common plugin. Then I created a update-site containing both features. I created a provision file in ccm/provision_profiles that points to the update-site, and with the feature-id of the service. 
Before restarting the server i request a reset by calling https://server/ccm/admin/cmd/requestReset .
When the server starts up after that it gives the following warning: 
Failed to resolve the bundle "com.example.hellojazz.service"
And the service is not listed when requesting  https://server/ccm/service as it is when i run it on the Jetty server.

I also tried to create just one feature containing both the service and common project, but that also does not work. 

Anyone who can help ? 

All kind of help would be appreciated.

2 answers



permanent link
Ralph Schoon (55.5k23642) | answered Mar 20 '13, 9:13 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Martin,

I would like to suggest to look into this article. Be sure to run it with the version 4.0 and not another version. However, the article has a lot more details also on how to debug extensions and make sure they would work before deployment. You can find also more information on my blog.

The issue you have is due to errors in the deployment. It misses information like the metainf or plugin. xml, there are inconsistencies in the plugin ID's, you miss the component. Likely something like that, because the deployment worked, but the bundle can not be found.

Comments
Martin Dam Pedersen commented Apr 02 '13, 9:34 a.m.
Hi Ralph,

 I have now followed the instructions in the paper RTC40ExtPoT.pdf, and it gave me the exact same error:
CRJZS0383W Failed to resolve the bundle "com.example.hellojazz.service".

I loaded the hellojazz code from the zip file, and did not make any modifications to it at all. Here is what i did:
1) I created a feature project and a updatesite, as stated in the above document.
2) Added the updatesite to the site folder on the server, and copied the site to it.
3) Created a hellojazz.ini file in provision_profiles folder.
5) Restarted the server.

Then I get the exact same error as typed in my first post.

if it is possible for you to deploy the hellojazz service, then please provide me with your feature and updatesite project, so I can see what i am doing wrong. 

Ralph Schoon commented Apr 02 '13, 9:45 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Martin,

where is that code for download? Please be aware that https://jazz.net/library/article/118/ talks about RTC 2.0. If I find time and can download the code, I might choose to try. Otherwise it is almost impossible to guide with that few information.  Failed to resolve the bundle indicates something could not been found. Potentially due to the update site project.


Martin Dam Pedersen commented Apr 02 '13, 9:46 a.m.

 Heres is what i get when calling https://server:9443/ccm/admin#action=com.ibm.team.repository.admin.componentStatus


permanent link
Ralph Schoon (55.5k23642) | answered Apr 02 '13, 10:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Apr 02 '13, 10:22 a.m.
Hi, I just downloaded the zip from the article.

  1. I imported the projects.
  2. I added Service and Common to the Jetty server launch.
  3. I ran it on my Jetty Test server (4.0.1, but should not matter) with that launch.  
  4. I added Client, common and UI actions to the Eclipse client launch. 
  5. I ran my test client with that launch.
Everything went fine it works in client and server, it shows in the component. So I must assume your Feature or Update site is missing something e.g. not both projects service and common or is not deployed correctly.



Comments
Martin Dam Pedersen commented Apr 03 '13, 4:14 a.m.

 Hi Ralph,


Thank you for your effort in helping me out here :-)

As I wrote in the question it also works fine for me when using the Jetty server, but it doesn't  work when i'am trying to deploy it on a standalone server. 

I have tried fiddling with the plugin ID's but with no luck.
I checked the jars in the update-site and they all contain the right class files(to my knowledge) and also plugin.xml + metainf.

I'am really surprised that it is such a pain for me, since it sounds so simple.

Are you able to deploy to a standalone Apache Server running the JazzTeamServer ?

If it could be of any help I could try emailing you my feature and update-site projects ?

Your answer


Register or to post your answer.