It's all about the answers!

Ask a question

How to install RTC 4 with Eclipse 3.7.x on 64 Bit Ubuntu 12.10

demetrios dimatos (1112) | asked Feb 21 '13, 7:14 p.m.
I have Ubuntu 64 Bit 12.10, RTC 4.0 both Eclipse 3.7.2 and 4.2.1 and when in the Team Advisor, the embedded browser displays:
"Failed to create web browser. Instructions for configuring the embedded browser can be found here:"

When I start eclipse I get an XPCOMM error:
       XPCOM error 0x80004005 , if I have set -Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner
       I have tried also setting this path to /usr/lib/firefox /usr/lib/mozilla and even a 32 bit xulrunner
When I don't set the XULRunnerPath the XPCOMM I get a different XPCOMM error:
      XPCOM error -2147467259

I have tried even writing a script that sets some ENV's:
    #export MOZILLA_FIVE_HOME=/usr/lib/webkitgtk-3.0-0/libexec
    export MOZILLA_FIVE_HOME=/usr/lib/firefox
    eclipse $*

I know I am running an unsupported version of Ubuntu but in the past I have always been able to point it to an xulrunner on Linux Mint 11 (32 bit) , Ubuntu 10, 11 (32 bit) and it has always worked. This is my first experience with the 64Bit Arch. I did follow both these posts and many more:

2 answers

permanent link
Tim Mok (6.6k38) | answered Feb 22 '13, 9:55 a.m.
You'll need a 64-bit xulrunner, which I believe is only available in nightly builds.

demetrios dimatos commented Feb 22 '13, 1:24 p.m.

Thanks Tim,
I did tried the nightly build, matched the right xulrunner to my eclipse release using this link:
Tried it for both my eclipse installs 3.7.2 and 4.2 both resulting in an XPCOMM error noted above.
I also had gotten the x686 xulrunner before from here before posting originally:
Thanks for trying to help.

Tim Mok commented Feb 22 '13, 4:52 p.m.
JAZZ DEVELOPER Did you specify the xulrunner to use by editing the eclipse.ini file? That's what I did with my 64-bit install.

demetrios dimatos commented Feb 25 '13, 1:51 p.m.

I did specify it in the eclipse.ini as well as trying to craft the other script solution. I am not unfamiliar with this problem its been something I had to deal with the last 2 years using RTC and Eclipse since 3.6.2.

permanent link
demetrios dimatos (1112) | answered Feb 25 '13, 2:00 p.m.
Although not a solution, Ubuntu 12.10 64bit on the W520 hardware has been nothing but problematic (many other issues) and I do need this PC to do my job. I decided to install Ubuntu 12.04 LTS 32 Bit and reverted back to my last known successful pairing; Eclipse 3.6.2 and RTC At least this way can take my time to find a solution for RTC 4.x.

This pairing will need you to specify the xulrunner in the eclipse.ini file, I used xulrunner 1.9.2, hope this helps others.

Tim Mok commented Feb 25 '13, 2:22 p.m.

I'm also running on a W520 with Linux Mint 14 and I'm using Eclipse 3.8.1 + RTC 4.0.3 M1 using xulrunner 1.9.2 (build id: 20101227033307). Hopefully, that will help narrow down the problem.

Your answer

Register or to post your answer.