It's all about the answers!

Ask a question

RTC version mismatch error.


Sterling Ferguson-II (1.6k7249256) | asked Feb 18 '13, 3:00 p.m.
edited Feb 19 '13, 6:06 p.m. by Susan Lafera (11)
CLM 4.0
RTC Eclipse client 4.0.0.1

Are these compatible?

http://www-01.ibm.com/support/docview.wss?uid=swg21623665&myns=swgrat&mynp=OCSSCP65&mync=E

Does not go in to these specific versions...I thought all of 4.0.0.x would be compatible...

Error running operation 'Open assigned to me'

CRJAZ1241I There is a version mismatch for the "com.ibm.team.workitem.query" model.  The server version is "6" while the client version is "7". Both client and server version must match. Check the overall version of the client using Help->About and ensure it is compatible with server version "4.0" and build id "RJF-I20120531-1400".
CRJAZ1241I There is a version mismatch for the "com.ibm.team.workitem.query" model.  The server version is "6" while the client version is "7". Both client and server version must match. Check the overall version of the client using Help->About and ensure it is compatible with server version "4.0" and build id "RJF-I20120531-1400".

Accepted answer


permanent link
Geoffrey Clemm (29.4k23035) | answered Feb 18 '13, 4:35 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Unfortunately, the "client must be no later than the server rule" includes 4'th digit ("fix pack") releases.  A work item has been submitted requesting that all 4'th digit client releases be compatible with any server release that only differs in the 4'th digit:
RTC servers at version N.a.b.x should be compatible with any client at version N.a.b.y, even when y is greater than x. (237832)
Please feel free to add a comment indicating your interest/support.
Sterling Ferguson-II selected this answer as the correct answer

Comments
Sterling Ferguson-II commented Feb 19 '13, 9:46 a.m.

Thanks Geoffrey,


I didn't know. You don't get that explanation from this page:


Geoffrey Clemm commented Feb 19 '13, 1:22 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Yes, I was also misled by that page (:-).

One other answer



permanent link
Ken Tessier (84117) | answered Feb 25 '13, 10:24 a.m.
In 4.0.1, we've added this Help topic that describes the client-server version compatibility:

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.jazz.install.doc/topics/c_n-1.html

Ken

Comments
Kevin Ramer commented Feb 24 '14, 2:41 p.m.

For what it's worth, I ran into this with a specialized client and found the only solution was to get all com.ibm.team*.jar files from the plain java libraries version that matched our servers.   Just updating the com.ibm.team.workitem.client, com.ibm.team.workitem.common was insufficient.

Your answer


Register or to post your answer.