It's all about the answers!

Ask a question

Gettting "Error while adding servlet mapping" for


Muhammad Arif (1143) | asked Nov 03 '08, 6:31 p.m.
Setup: RQM 8.0 (GM build) in WAS 6.1.0.17 on Win2K3 SP2 with DB2 enterprise.

I am trying to install RQM in WAS with LDAP authentication but can't save the LDAP settings in "jazz/admin" page. There are too many problems, but let's start with this one first. This problem is related to the problem I submitted a few minutes ago which was about ADMIN appearing as the logged in user when it was the user.

After installing RQM (jazz.war and help.war) in WAS, enabling LDAP authentication, and setting genericJVMArguments for the server. I stop the WAS instance and restart it. When I restart the server, the WAS systemout.log file shows the following error for jazz.war and help.war files.
00000015 WebApp W Error while adding servlet mapping --> /* Please set fileServingEnabled=false in the ibm-web-ext.xmi file which is under WEB-INF folder.

Prior to installing RQM for this time, I have been installing and uninstalling RQM again and again. Between every unisntall and reinstall, I delete the RQM cache from <WAS_PROFILE>/temp/<node>/server1, but not touching "<PROFILE_NAME>\installedApps\rptram1Node01Cell\jazz_war.ear". After uninstalling RQM, how can I remove this servlet mapping. Do I need to remove jazz_war.ear and help.ear directories from the installedApps dir?

Following is the excerpt from Systemout.log with a few lines before and after the error. Please see the line after the error showing Web Module <null> has been bound .... What does it mean?

00000015 ApplicationMg A WSVR0200I: Starting application: jazz_war
00000015 ApplicationMg A WSVR0204I: Application: jazz_war Application build level: Unknown
00000013 ServletWrappe I SRVE0242I: : Initialization successful.
00000013 VirtualHost I SRVE0250I: Web Module isclite has been bound to admin_host
  • .
    00000015 WebGroup A SRVE0169I: Loading Web Module: jazz.war.
    00000015 ServletWrappe I SRVE0242I:
  • : Initialization successful.
    00000015 WebApp W Error while adding servlet mapping --> /* Please set fileServingEnabled=false in the ibm-web-ext.xmi file which is under WEB-INF folder.
    00000015 VirtualHost I SRVE0250I: Web Module <null> has been bound to default_host
  • .
    00000014 WebGroup A SRVE0169I: Loading Web Module: Default Web Application.
    00000015 ApplicationMg A WSVR0221I: Application started: jazz_war
  • One answer



    permanent link
    Matt Lavin (2.7k2) | answered Nov 04 '08, 8:48 a.m.
    FORUM MODERATOR / JAZZ DEVELOPER
    The error message

    00000015 WebApp W
    Error while adding servlet mapping --> /* Please set
    fileServingEnabled=false in the ibm-web-ext.xmi file which is under
    WEB-INF folder.

    is normal, and can be ignored. When re-installing the WARs into WAS,
    the approach I take is:

    1. Stop and Uninstall the WARs through the Integrated Solutions Console
    2. Restart WAS
    3. Install the WARs through the Integrated Solutions Console.

    Those steps work well for me. The subject of your message said
    something about "Error while adding servlet mapping", but I don't see
    that mentioned in the content of your post. Can you describe again how
    you see that problem? Does it happen when you install the jazz.war or
    the help.war?


    Matt Lavin
    Jazz Server Team


    arifismail wrote:
    Setup: RQM 8.0 (GM build) in WAS 6.1.0.17 on Win2K3 SP2 with DB2
    enterprise.

    I am trying to install RQM in WAS with LDAP authentication but can't
    save the LDAP settings in "jazz/admin" page. There are too
    many problems, but let's start with this one first. This problem is
    related to the problem I submitted a few minutes ago which was about
    ADMIN appearing as the logged in user when it was the user.

    After installing RQM (jazz.war and help.war) in WAS, enabling LDAP
    authentication, and setting genericJVMArguments for the server. I
    stop the WAS instance and restart it. When I restart the server, the
    WAS systemout.log file shows the following error for jazz.war and
    help.war files.
    00000015 WebApp W
    Error while adding servlet mapping --> /* Please set
    fileServingEnabled=false in the ibm-web-ext.xmi file which is under
    WEB-INF folder.

    Prior to installing RQM for this time, I have been installing and
    uninstalling RQM again and again. Between every unisntall and
    reinstall, I delete the RQM cache from
    WAS_PROFILE>/temp/<node>/server1, but not touching
    "<PROFILE_NAME>\installedApps\rptram1Node01Cell\jazz_war.ear".
    After uninstalling RQM, how can I remove this servlet mapping. Do I
    need to remove jazz_war.ear and help.ear directories from the
    installedApps dir?

    Following is the excerpt from Systemout.log with a few lines before
    and after the error. Please see the line after the error showing
    Web Module <null> has been bound .... What does it mean?

    00000015 ApplicationMg A WSVR0200I:
    Starting application: jazz_war
    00000015 ApplicationMg A WSVR0204I:
    Application: jazz_war Application build level: Unknown
    00000013 ServletWrappe I SRVE0242I:
    : Initialization
    successful.
    00000013 VirtualHost I SRVE0250I: Web
    Module isclite has been bound to admin_host
  • .
    00000015 WebGroup A SRVE0169I:
    Loading Web Module: jazz.war.
    00000015 ServletWrappe I SRVE0242I:
  • : Initialization
    successful.
    00000015 WebApp W Error while
    adding servlet mapping --> /* Please set fileServingEnabled=false
    in the ibm-web-ext.xmi file which is under WEB-INF folder.
    00000015 VirtualHost I SRVE0250I: Web
    Module <null> has been bound to
    default_host
  • .
    00000014 WebGroup A SRVE0169I:
    Loading Web Module: Default Web Application.
    00000015 ApplicationMg A WSVR0221I:
    Application started: jazz_war
  • Your answer


    Register or to post your answer.