It's all about the answers!

Ask a question

Test Environment field is not reflecting by default


Rajat Singh (59833543) | asked Dec 16 '12, 3:42 a.m.
Hi Team

I have created a test plan in RQM 4.0.1. Entered the schedule for it and created one test environment.
Now when I try to run this test case directly from a test plan, it pops up the 'Run Test Case' window.



I can see that the Test Plan and Iteration are selected as per the values I have entered.
However, for test environment, it does not take the environment that I have created for the test plan.
It shows as 'Unassigned' and I have to manually click on the drop down to select the environment.

We can generate test execution records for these test cases by selecting the environment.
However, some testers directly run the test case.
In such scenarios we get the results for Test Environments as 'Unassigned'.

Is there a way to populate the default value of test environment when running the test case directly, or atleast a condition that does not allow the execution if the test environment is set as 'Unassigned'.

Any inputs on this is much appreciated,

Best Regards
Rajat

One answer



permanent link
Pramod Chandoria (2.1k11220) | answered Dec 16 '12, 1:35 p.m.
JAZZ DEVELOPER
Hi Rajat,
It is difficult to select any of the Test Environment because there can be multiple test environments created for a Test plan. However I like your suggestion to enable process for making Test environment a mandatory attribute of TCER. I saw somewhere similar need for Test schedule and Test plan of the TCER. Please submit the request

Your answer


Register or to post your answer.