It's all about the answers!

Ask a question

Disabling the email notification for some period of time..


Qaiser Islam (31256165) | asked Oct 25 '12, 6:32 a.m.

Hi,

We are importing large number of exisiting WI's from another system. to avoid sending the emails to the reciepient. we set the email notification property 'false'. but it appears that messages are being queued and when we revert back to 'true'. they start getting the bulk emails.

Is it correct behavior of RTC?

Regards,

Qaiser

Accepted answer


permanent link
sam detweiler (12.4k6173200) | answered Dec 04 '15, 3:33 p.m.
yeh, what crazy behavior.. I wrote a little tool to disable notifications for a list of users, so that emails don't even get queued.

see the code in the second answer here

https://jazz.net/forum/questions/137079/resolved-not-a-bug-with-user-mail-settings-and-receivemails

Qaiser Islam selected this answer as the correct answer

One other answer



permanent link
katherine szczech (111) | answered Dec 04 '15, 3:28 p.m.
I've seen this behavior in RTC 5.0.2 and I believe the trick is to not "enable" email notification soon after the migration/import of the work items have been completed.  There was a technote http://www-01.ibm.com/support/docview.wss?uid=swg21391225 that recommends waiting for e.g. 10 min. before you re-enable email notification.  I am investigating to see if there is a way to view what email notifications are queued up and what how does one determine how long one should wait before re-enabling email after the work item import/migration.  I'd assume the more work items your are importing/migrating, the longer you need to wait before you re-enable email notification.

Your answer


Register or to post your answer.