It's all about the answers!

Ask a question

installing RRDI 2.0 on an existing Oracle DW on JTS 3.0.1.1


Keng Lim (633) | asked Sep 10 '12, 8:13 a.m.
 I am trying to install RRDI 2.0 to an existing JTS 3.0.1.1 instance that is already using an Oracle database.

The RICM connected OK on the setup.

However I am now on the Configure Data Warehouse page and when defining my existing Oracle DW datastore,
I get error message .......

CRRRA0131E : An error happened when validating the database .......
ERROR : ORA-00942 : table or view does not exist.

I think I need to run an upgrade script on the existing DW but which one ? 

2 answers



permanent link
Marc Nehme (27657) | answered Sep 11 '12, 12:33 p.m.
JAZZ DEVELOPER
Hi Keng, is there more information regarding this error reference which table or view is missing? Can you check the rrdi_setup.log located in <rrdiinstalldir>\setup\logs and check for more info around which table/view the wizard is complaining about?

Comments
Keng Lim commented Sep 11 '12, 3:17 p.m.

Hi Marc, i did check the logs. Same message as the one posted. Nothing more. I will need to check with the dba to see if they is anything in oracle. Do you know of any switch/setting ?


Krzysztof Ka┼║mierczyk commented May 06 '13, 7:45 a.m.

Hi Keng,
Did you have the chance to fix this? What was the root cause of the issue?


-1
permanent link
Mark Prout (13411510) | answered Sep 10 '12, 11:17 a.m.
I'm not sure that this is even a supported environment, RRDI 2.0 is for use only against CLM v4.  When upgrading to CLM v4 you need to upgrade the DW.

Comments
Keng Lim commented Sep 10 '12, 11:23 a.m.

Hi Mark, I believe it is.

Goto to the RRDI 1.0.2 download site from CLM 3 optional downloads. It will tell you that it is best to use the latest version and leads you to RRDI 2.0

However if you have the instructions to upgrade the DW the do pass them on


Mark Prout commented Sep 10 '12, 11:53 a.m.

Hi Keng

The following link is useful; https://jazz.net/help-dev/clm/topic/com.ibm.rational.rrdi.admin.doc/topics/c_upgrading_rrdi.html

If it was possible to upgrade just the DW I am unaware of any published way to upgrade the Java based ETLs found within each of the CLM pillars to v4 ETLs, this could prove to be the next challenge.

Your answer


Register or to post your answer.