It's all about the answers!

Ask a question

Jazz Build Engine in RTC failed to connect to BuildForge


Hui Bin Shi (28179) | asked Aug 14 '12, 9:20 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
edited Aug 27 '12, 5:22 a.m.
 
2012-08-14 03:19:50,437 [              WebContainer : 8]  WARN .team.repository.servlet.AbstractTeamServerServlet  - CRJAZ1163I IllegalArgumentException processing POST         request for com.ibm.team.build.internal.common.ITeamBuildService.getBuildResultContributions(). CRJAZ1170I The request was made by user "user@company.com" from "sig        -9-145-223-2.de.ibm.com".CRJAZ1166I The stack trace hash is C349A5D339C5C74DC07E5FC6003A44DFB58B7BC3.
  24242 java.lang.IllegalArgumentException: The parameter "buildResultHandle" must not be null.


Comments
David Olsen commented Aug 14 '12, 2:24 p.m.
JAZZ DEVELOPER

What are the versions of the JBE and the RTC server? Is there a version mismatch?


Hui Bin Shi commented Aug 15 '12, 3:27 a.m. | edited Aug 15 '12, 3:28 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

4.0 for both server and JBE.

4 answers



permanent link
Karl Weinert (2.0k42536) | answered Aug 15 '12, 7:51 a.m.
JAZZ DEVELOPER
Could you provide a few more details such as the command you started the JBE with. The steps you followed to set up the build definition. What you did just before you see the error message. Where are you seeing the error message?

Can you test with "The simplest possible Jazz-based build"  to make sure everything is working?

Comments
Julien Delgoulet commented Aug 22 '12, 8:57 a.m.

Jbe command line based builds work great.


permanent link
Hui Bin Shi (28179) | answered Aug 15 '12, 3:27 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
4.0 for both server and JBE.

permanent link
Hui Bin Shi (28179) | answered Aug 17 '12, 4:24 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
This issue should be related with the SSL. The JBE is able to connect to the server without SSL enabled.  At server side. I've already done the following steps according to the online help. But it doesn't seem working.

Optional: To configure SSL:
 a)  Create a folder named buildforge_conf. For Apache Tomcat server, create the buildforge_conf folder under JazzInstallDir/server/. For Websphere Application Server, create the buildforge_conf folder under WASInstalldir/profiles/AppDir.  --- Done
 b)  Under the buildforge_conf folder, create a subfolder for each Build Forge deployment that you want to connect to securely. Use the naming convention hostname_port. For example, JazzInstallDir/server/buildforge_conf/9.37.30.218_49150 or WASInstalldir/profiles/AppDir/buildforge_conf/9.37.30.218_49150. The host name must match the value on the Build Engine configuration page.   -- Done
 c)  Copy the bfclient.conf and buildforge truststore (p12 or jks) files from the Build Forge deployment into each Build Forge deployment subfolder.   -- Done
    Note: The truststore files (p12 or jks) must be at the same level as bfclient.conf and the references to these files from bfclient.conf must use absolute paths.

Comments
Spencer Murata commented Aug 17 '12, 9:39 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Those are the SSL steps for setting up the Build Forge integration, which doesn't have anything to do with JBE. I would suspect that, assuming you are using JBE from Build Forge, that there is a problem with the environment not getting set in BF for a proper JBE run.


Julien Delgoulet commented Aug 22 '12, 8:54 a.m.

Well, as far as I know the only integration between Buildforge and RTC is thru the JBE adaptor. (which simply launch the jbe on request).

To resume the situation and give some updates : Everything was working fine when RTC was 3.x as soon as we updated to 4.0, ssl connection did not work anymore and so much more ...

Now that we moved to 4.0 : - Buildforge build engine are always marked with "warning - The build engine process may not be running" : if I do a "Test connection, test ends up succesfully).

  • When I kick off a build from RTC (right click - request a build then submit) I get a popup saying that my build do not appear to be processing request BUT, if I do the same request and update the Build Engine property (in the request pop up) with the buildforge build engine, then the build is kicked off ... (Looks like there is something broken between builds engine and build definition).

  • Also when builds run into buildforge I get no progess in RTC (the build status is always "no progress information" and never ends - even if the build is finished on the buildforge side ...) so I have to check into buildforge that my build is finished then do an "Abandon" in RTC....


Julien Delgoulet commented Aug 22 '12, 9:23 a.m.

@Spencer. Seems like you get confused by this thread title. What we are trying do is create a buildforge buildengine that connects to buildforge securely. It was working in 3.x before our move to 4.0.


permanent link
Hui Bin Shi (28179) | answered Aug 27 '12, 5:19 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
It is now fixed after the bfclient.conf is updated to use the absolute paths for the truststore files. Sorry for the confusion of the thread title and thank everybody for the replies!

Copy the bfclient.conf and buildforge truststore (p12 or jks) files from the Build Forge deployment into each Build Forge deployment subfolder.
Note: The truststore files (p12 or jks) must be at the same level as bfclient.conf and the references to these files from bfclient.conf must use absolute paths.

Your answer


Register or to post your answer.