It's all about the answers!

Ask a question

SVN Dump Format/Encoding Question

Joshua Giangrande (2611216) | asked Apr 30 '12, 8:00 p.m.
Hey everyone,

I'm working on importing data from our current source control system into RTC, and am running into a bit of a snag. I seem to be running into an error where everything wants to import as text/plain with ISO-8859-1 encoding, unless an encoding was specified in the document itself (several xml files have imported correctly because a tag identifies them as using UTF-8 encoding). Realizing this is not what I wanted, I took a small dump file I had lying around and began manually fiddling with it before I made the appropriate changes to my code which generates the dump files for me.

I have determined that I can change the text/plain value to what I want by adding a key of "svn:mime-type" with a value of "text/plain", like so:

K 13
V 10

However, I cannot for the life of me figure out how to change the encoding in the same way. I did some research online and found what appeared to be various svn command line calls that were formatted like this:

svn propset "svn:mime-type" "text/plain;encoding=UTF-16LE"

This initially made me believe that I could pass "text/plain; encoding=UTF-8" as a value to the key of svn:mime-type. RTC, however, interpreted this as me trying to set the Content MIME-Type field to the literal string "text/plain; encoding=UTF-8" which is not what I want. I have also tried substituting the word "encoding" with "charset," which I saw in another example, and achieved the same results. I have tried adding a key of "svn:encoding" with a value of "UTF-8," and RTC seems to skip over the key altogether (I assume it never was or is no longer a recognized key word).

If anyone knows how to modify a dump file to change the Text File Encoding field in RTC I would greatly appreciate your guidance.

- Josh

edit: removed extraneous code tag, added more detail to first paragraph.

Be the first one to answer this question!

Register or to post your answer.