It's all about the answers!

Ask a question

Memory Problem for RTC Server


Ashish Sahoo (2176) | asked Mar 21 '11, 1:44 p.m.
We had implemented the only the RTC WAS server hosted on an Linux box for our client which having 4GB memory with swap itz having 4828 mb and db2 on other box and having not more than 150 user using it actively(that to not on single time zone). I am experiencing out of memory problem on regular interval for the RTC WAS server for which i need to recycle the server regularly. Is there any setting do i need to do for WAS server or for Linux. Please help me out.

6 answers



permanent link
Anthony Kesterton (7.5k5177136) | answered Mar 22 '11, 4:40 a.m.
JAZZ DEVELOPER
We had implemented the only the RTC WAS server hosted on an Linux box for our client which having 4GB memory with swap itz having 4828 mb and db2 on other box and having not more than 150 user using it actively(that to not on single time zone). I am experiencing out of memory problem on regular interval for the RTC WAS server for which i need to recycle the server regularly. Is there any setting do i need to do for WAS server or for Linux. Please help me out.


Definitely raise this with the IBM support desk.

Also - when you say "out of memory" - is this an RTC message or an OS (Linux) message?

What are your memory settings on RTC? If you have 4GB physical memory, you may want to reduce the RTC/JVM memory consumption to less than 4Gig.

anthony

permanent link
Ashish Sahoo (2176) | answered Mar 22 '11, 4:51 a.m.
We had implemented the only the RTC WAS server hosted on an Linux box for our client which having 4GB memory with swap itz having 4828 mb and db2 on other box and having not more than 150 user using it actively(that to not on single time zone). I am experiencing out of memory problem on regular interval for the RTC WAS server for which i need to recycle the server regularly. Is there any setting do i need to do for WAS server or for Linux. Please help me out.


Definitely raise this with the IBM support desk.

Also - when you say "out of memory" - is this an RTC message or an OS (Linux) message?

What are your memory settings on RTC? If you have 4GB physical memory, you may want to reduce the RTC/JVM memory consumption to less than 4Gig.

anthony

i generally getting java.lang.OutOfMemoryError on WAS logs when RTC got hung. is there any option that RTC can be run lower memory option? Linux box having 4Gb physical memory.

permanent link
Ashish Sahoo (2176) | answered Apr 03 '11, 1:17 p.m.
We had implemented the only the RTC WAS server hosted on an Linux box for our client which having 4GB memory with swap itz having 4828 mb and db2 on other box and having not more than 150 user using it actively(that to not on single time zone). I am experiencing out of memory problem on regular interval for the RTC WAS server for which i need to recycle the server regularly. Is there any setting do i need to do for WAS server or for Linux. Please help me out.


Definitely raise this with the IBM support desk.

Also - when you say "out of memory" - is this an RTC message or an OS (Linux) message?

What are your memory settings on RTC? If you have 4GB physical memory, you may want to reduce the RTC/JVM memory consumption to less than 4Gig.

anthony
Hello Anthony,
I am very much thankful to you as for your quick response for our this problem. Looking forward we will take much help from you or from your team. Many many thanks a lot Anthony as per your proper guidance to us.
With Regards,
Ashish K Sahoo

permanent link
Ales Koprivnikar (116352) | answered Apr 04 '11, 4:05 a.m.
Ashish,
so not 100% sure, but this sometimes helps with the OOMs

-XX:MaxPermSize=128m

If 128 still gives you trouble, try 256.

Regards,
Ales

permanent link
Jared Russell (1.3k12019) | answered Apr 04 '11, 4:44 a.m.
Have you increased the JVM Maximum Heap Size as per the instructions here: http://jazz.net/library/article/549/ ?

Now we need to set the JVM heap sizes. Note that the values used here are only examples and should be changed to suite your particular environment. Navigate to Servers > Server Types > Websphere application servers > Server1. Under Server Infrastructure, click Java and Process Management > Process definition. Under Additional Properties, click Java Virtual Machine. Add the value 100 to the Initial Heap. Add the value 4096 to the Maximum Heap Size.


Note that this assumes you're running on a 64-bit OS, if you're running a 32-bit OS you'll need to set the maximum heap quite a bit lower (1492 iirc).

permanent link
Ashish Sahoo (2176) | answered Apr 04 '11, 4:50 a.m.
itz 64bit OS with RED HAT Linux 5.5 Server installed. I had set the JVM initial heap size to 256M and Maximum heap size to 1024M.

Your answer


Register or to post your answer.