It's all about the answers!

Ask a question

Reports missing from viewlet options


Jeffrey Neau (11112113) | asked Apr 30 '10, 1:15 p.m.
I'm using Team Concert 2.0.

Simple Team Process

I've configured a few reports and can see/run them in the "Reports" section of the project website.

However, when I try to add a viewlet containing a report, the "Reports" option does not show up as a viewlet type. I get "Build", "ClearQuest", "Feeds", "General", "Help", "Plans", "Project/Team" and "Work Items"....but no "Reports".

Is there something I need to configure for it to show?

7 answers



permanent link
James Moody (3.3k24) | answered Apr 30 '10, 1:50 p.m.
JAZZ DEVELOPER
On 4/30/2010 1:22 PM, jneau wrote:
I'm using Team Concert 2.0.

Simple Team Process

I've configured a few reports and can see/run them in the
"Reports" section of the project website.

However, when I try to add a viewlet containing a report, the
"Reports" option does not show up as a viewlet type. I get
"Build", "ClearQuest", "Feeds",
"General", "Help", "Plans",
"Project/Team" and "Work Items"....but no
"Reports".

Is there something I need to configure for it to show?


There's nothing special you should have to configure here. I'll ask the
dashboard team to follow up with any suggestions.

james
RTC Reports Team Lead

permanent link
Jeffrey Neau (11112113) | answered Apr 30 '10, 2:15 p.m.
Thanks James.

If it matter, this was a project that originated in RTC 1.0 and was migrated to 2.0.

permanent link
Mike Pawlowski (6861) | answered May 06 '10, 3:24 p.m.
JAZZ DEVELOPER
Hi Jeffrey,

Just to confirm, when you say "the Reports option does not show up" you mean the "Reports" viewlet category in the Viewlet Chooser correct?

I tried creating a new project area using the Simple Team Process template (using RTC 3.0 M5). The project area does not appear to have any report templates deployed to it on creation (in contrast to the Scrum, OpenUp templates) as confirmed by the Reports Web UI (when within that project area) and the Team Artifacts view for that project area. I think for the 2.0 release, the Viewlet Chooser does not show report viewlets if their corresponding report template is not deployed and the Reports category won't show up if it has no children. So maybe I'm missing something...
In my case, I do see the Reports category and viewlet entries; but, when I try to add a reports viewlet to the dashboard I get the following error message in the viewlet content area: Report with ID 'workitems.MicroBurnup' is not deployed to project area 'Simple'. Click here to select a different project area.

Can you confirm that your project area with the Simple Team Process has report templates deployed to it (including the 'micro' reports used for viewlet report rendering)?

Thanks,

permanent link
Jeffrey Neau (11112113) | answered May 07 '10, 6:23 p.m.
Hi Jeffrey,

Just to confirm, when you say "the Reports option does not show up" you mean the "Reports" viewlet category in the Viewlet Chooser correct?

I tried creating a new project area using the Simple Team Process template (using RTC 3.0 M5). The project area does not appear to have any report templates deployed to it on creation (in contrast to the Scrum, OpenUp templates) as confirmed by the Reports Web UI (when within that project area) and the Team Artifacts view for that project area. I think for the 2.0 release, the Viewlet Chooser does not show report viewlets if their corresponding report template is not deployed and the Reports category won't show up if it has no children. So maybe I'm missing something...
In my case, I do see the Reports category and viewlet entries; but, when I try to add a reports viewlet to the dashboard I get the following error message in the viewlet content area: Report with ID 'workitems.MicroBurnup' is not deployed to project area 'Simple'. Click here to select a different project area.

Can you confirm that your project area with the Simple Team Process has report templates deployed to it (including the 'micro' reports used for viewlet report rendering)?

Thanks,


Hi Mike,

Yes, I'm attempting to add a viewlet from the Viewlet Chooser, and I have no Report root type listed in the tree.

This project is using a Simple Team Process (originally created in RTC 1.0) I have deployed a few reports that are available when I go to the "Reports" section of my project area and they work fine.

Now, I want to add one of them to the dashboard, but don't even have the option to add reports.

permanent link
Jeffrey Neau (11112113) | answered May 07 '10, 6:23 p.m.
UPDATE:

I just read your comment about the "micro" reports. I added one of those and NOW the reports option is available in the viewlet chooser and only lets me add the micro report types.

Are those the only ones that are supposed to be available on the dashboard?

permanent link
Mike Pawlowski (6861) | answered May 10 '10, 1:29 p.m.
JAZZ DEVELOPER

Are those the only ones that are supposed to be available on the dashboard?


Yes, those are the only ones.

Each normal-sized BIRT report template should have a corresponding micro-sized BIRT report template (in the 'micro' folder) that is used exclusively for displaying content within Web Dashboards through the Trend Reports viewlet.

Clicking on a configured Trend Report viewlet's title hyperlink will drill into the Reports Web UI and show the corresponding normal-sized BIRT report generated using the same report query.

permanent link
James Moody (3.3k24) | answered May 13 '10, 9:22 a.m.
JAZZ DEVELOPER
On 5/7/2010 6:37 PM, jneau wrote:
mpawlowwrote:
Hi Jeffrey,

Just to confirm, when you say "the Reports option does not show
up" you mean the "Reports" viewlet category in the
Viewlet Chooser correct?

I tried creating a new project area using the Simple Team Process
template (using RTC 3.0 M5). The project area does not appear to have
any report templates deployed to it on creation (in contrast to the
Scrum, OpenUp templates) as confirmed by the Reports Web UI (when
within that project area) and the Team Artifacts view for that
project area. I think for the 2.0 release, the Viewlet Chooser does
not show report viewlets if their corresponding report template is
not deployed and the Reports category won't show up if it has no
children. So maybe I'm missing something...
In my case, I do see the Reports category and viewlet entries; but,
when I try to add a reports viewlet to the dashboard I get the
following error message in the viewlet content area: Report with ID
'workitems.MicroBurnup' is not deployed to project area 'Simple'.
Click here to select a different project area.

Can you confirm that your project area with the Simple Team Process
has report templates deployed to it (including the 'micro' reports
used for viewlet report rendering)?

Thanks,

Hi Mike,

Yes, I'm attempting to add a viewlet from the Viewlet Chooser, and I
have no Report root type listed in the tree.

This project is using a Simple Team Process (originally created in RTC
1.0) I have deployed a few reports that are available when I go to the
"Reports" section of my project area and they work fine.

Now, I want to add one of them to the dashboard, but don't even have
the option to add reports.


You'll need to deploy the "Micro" versions of these reports if you want
them to work in the dashboard.

james
RTC Reports Team Lead

Your answer


Register or to post your answer.