It's all about the answers!

Ask a question

error when submitting assets via RMC, using ClearCase UCM


Derek Baron (6632) | asked Apr 07 '10, 1:45 p.m.
JAZZ DEVELOPER
I'm posting this on behalf of Todd Dunnavant:

I have created sample RMC method plug-ins, under ClearCase UCM control, which I wish to turn into assets. Using the RAM Eclipse client, I select the contents of a plug-in and attempt to submit it. RMC churns away, I am asked to add the new .asset file and its enclosing directory to source control. I say "sure". RMC does more churning, and finally throws the following errors:

Title "Asset Management Error" -> "submission did not complete successfully". Reason: "Failed to check in asset file under UCM control"


Do any of you know why my view was unspecified? Given that the Navigator view clearly shows the ClearCase view that the plug-in lives in, I'm surprised that the RAM Eclipse client can't figure out which view to work with. I have tried this using both dynamic and snapshot views, and I have achieved the same results. Any ideas as to what I'm doing wrong?

One answer



permanent link
Srimanth Gunturi (206125) | answered Apr 07 '10, 6:53 p.m.
JAZZ DEVELOPER
Hello,
Is that error occurring when using a single stream UCM setup (it seems
to look like it)? If so it is not supported currently for reasons stated
above. If not please send us the .log file available at /.metadata/.log - this should contain the exception traces
which should help us better understand the problem.
Regards,
Sri.



On 4/7/2010 1:52 PM, ddbaron wrote:
I'm posting this on behalf of Todd
Dunnavant:

I have created sample RMC method plug-ins, under ClearCase UCM
control, which I wish to turn into assets. Using the RAM Eclipse
client, I select the contents of a plug-in and attempt to submit it.
RMC churns away, I am asked to add the new .asset file and its
enclosing directory to source control. I say "sure". RMC
does more churning, and finally throws the following errors:

Title "Asset Management Error" -
"submission did not complete successfully". Reason:
"Failed to check in asset file under UCM
control"

Do any of you know why my view was unspecified? Given that the
Navigator view clearly shows the ClearCase view that the plug-in
lives in, I'm surprised that the RAM Eclipse client can't figure out
which view to work with. I have tried this using both dynamic and
snapshot views, and I have achieved the same results. Any ideas as
to what I'm doing wrong?

Your answer


Register or to post your answer.