It's all about the answers!

Ask a question

svn import not detecting branch


Erik Rakhorst (212) | asked Dec 17 '09, 5:56 a.m.
Hi,
I am trying to import a svndumpfile.
The trunk import went Ok, but no baselines were created for the branches.
I manually created the baselines at the correct point in history.

Now when I try to import a branch it fails with a server error and in the logfile
I get the error:
Parent '' has multiple children with the name '######'
If I understand the documentation, the wizard should detect that it is a branch import and will probably act different.

It might be a problem with the svn layout. Those branches were created in the root and not in the branches directory.
svn layout:
\branchA
\branchB
\tags
\trunk

Any ideas on how to import the branches?

One answer



permanent link
Erik Rakhorst (212) | answered Dec 18 '09, 10:56 a.m.
I solved my problem.
Actually I worked around it.
I think something was wrong with the dumpfile.
Using the svn repository browser I succeeded in importing the trunk and the branches.

I had to manually create the branchpoint baselines, but at least I could import the branches without any problems.

Your answer


Register or to post your answer.