It's all about the answers!

Ask a question

No able to add built-in attribute "Start Date" to editor presentation


Abinaya Raghupathy (11) | asked Feb 07, 12:42 a.m.
Hello Team,

We are using (customized) SAFe template for our projects.
We have a requirement to add "Start Date" and "End Date" attributes to Task type.
In Task type, we already see a built-in attribute "Start Date". But, we are not able to add this built-in attribute to the editor presentation for some reasons.

If we now create a new attribute by the same name "Start Date", then the same name is seen twice while we try to select "Start Date" attribute in Query/JRS reports. This might be misleading for the users.

So, kindly let us know how to handle this use case ?

Version used: 7.0.2 SR1 iFix027

One answer



permanent link
Ralph Schoon (62.9k33645) | answered Feb 07, 11:00 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 I can't seem to find a place where the attribute startDate is used in the editor presentations. I can not find any reference to startDate or Start Date in the process.xml. There is a reference in the plan attribute mapping. It shows deprecated in the web UI and is not removable as far as I can tell. It might be some kind of remnant from the past.


I do not know what it does and where it would be used. To avoid confusing your users with a custom attribute with the same name, you can rename the display name e.g. to zzz_Start Date. You can now create a custom one with the original name. For new attributes you can use the external URI attribute to declare a more abstract type declaration. Attributes with the same external URI can be considered as the same attribute in reports, even if the attribute ID and name are different.

Your answer


Register or to post your answer.