It's all about the answers!

Ask a question

[DOORS NG 7.0.3] OpenSocial Widget Not Loading (CRJAZ5037E) Sandbox & Preview env


Ragavendhren Balasubramanain (111) | asked Jan 04, 9:31 a.m.
edited Jan 05, 3:52 a.m.

I'm encountering issues loading OpenSocial widgets in DOORS NG 7.0.3, both in sandbox and preview environments.

Here's what I've tried:

Simple "Hello World" widget:
Gadget.xml snippet:
<Module specificationVersion="2.0">
    <ModulePrefs title="open social widget test" height="680"></ModulePrefs>
    <Content type="html">
        <![CDATA[ <h3>Hello World!</h3> ]]>
    </Content>
</Module>

Wikipedia gadget (from documentation): https://www.gstatic.com/ig/modules/wikipedia/wikipedia_v2.xml

Both attempts result in the error: "The OpenSocial gadget was not loaded. ID CRJAZ5037E"


Tried in both sandbox and preview env: Version: 7.0.3
But widget is not getting loaded. Below error is shown
The OpenSocial gadget was not loaded.ID CRJAZ5037E

Additional observations:

Requesting assistance:

  • Has anyone else encountered this issue with OpenSocial widgets in DOORS NG 7.0.3?
  • Any suggestions for troubleshooting or potential solutions?

Appreciate any insights!

Additional details:

  • DOORS NG version: 7.0.3
  • Environments tested: Sandbox and preview

Thank you in advance for your help!


Accepted answer


permanent link
Edward Chan (554) | answered Jan 08, 6:13 p.m.

 You will need to ask an admin to make those changes if you don't have access to Advanced Properties.

Ralph Schoon selected this answer as the correct answer

Comments
Ragavendhren Balasubramanain commented Jan 12, 11:17 a.m.

 

I am accessing the sandbox/preview environment with URL like below,

when trying to access Lifecycle Project Administration page I get below message.

**************

Permission Denied

Your account does not have the group memberships required to access the requested resource.
********
Its a trail version right, still not hosted in our servers. 
How to proceed in this case. Whom should I contact for admin access.

Until I get this information, I am trying to access the artifact details using rest apis.
Is there any documention reg this. I couldn't find the endpoints and usage information.
For sandbox env, how do I do authentication (api keys ,etc)

3 other answers



permanent link
Paulo Giovani (11) | answered Jan 04, 7:51 p.m.

Hello my friend!


I had the same problem. For solution, I acessed the Jazz Server Admin page (https://[my hostname]:9443/jts). Then, in Advanced Properties, I searched for 'open' and in the Main Repository Component (com.ibm.team.repository.service.opensocial.gadgetprovider.OpenSocialGadgetProviderRestService), I changed the current value for the property of the 'list of allowed external resources' and did a restart in the server. For the current value, I used the extensions folder ->  https://[my hostname]:9443/extensions/ 

It's necessary to create an 'extensions' folder in the directory of Jazz Team Server. In my case, I used the following path:

C:...\IBM\JazzTeamServer\server\liberty\servers\clm\dropins\war\extensions\

Note that I created the folders dropins -> war -> extensions

I did not tested it in the sandbox version.

Hope it can help you!


Comments
Ragavendhren Balasubramanain commented Jan 05, 4:01 a.m.
Thanks for the answer, Paulo. Unfortunately, I don't have the options you mentioned, like whitelisting URLs, in my sandbox environment. I'm wondering if anyone has found a way to achieve the same functionality there.

permanent link
Hubert Aunkofer (383) | answered Jan 10, 6:52 a.m.

Comments
Ragavendhren Balasubramanain commented Jan 10, 12:24 p.m.

There is no administration privileges in Sandbox/Preview env. So not able to whitelist URL



permanent link
Ragavendhren Balasubramanain (111) | answered Jan 25, 2:10 a.m.

 So in cloud sandbox we can't do much. It is just to know what is what.


To try out our own extensions, install the trail version available at

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.