It's all about the answers!

Ask a question

I need Update java 1.8.0_161 / build 8.0.5.11 to version : build 8.0.7.10


Rodrigo Guedes Costa (255) | asked Jan 13 '23, 9:58 a.m.
edited Jan 13 '23, 10:03 a.m.

I need to update java from my RTC installation RTC (Rational Team Concert 6.0.6)


JazzTeamServer_606/server/jre/bin/java -version java version
"1.8.0_161"
Java(TM) SE Runtime Environment (build 8.0.5.11 - pxa6480sr5fp11-20180326_01(SR5 FP11))IBM J9 VM (build 2.9, JRE 1.8.0 Linux amd64-64 Compressed References 20180309_380776 (JIT enabled, AOT enabled)OpenJ9 - 49fcaf39
OMR - 5cbbadf
IBM - 4453dac)
JCL - 20180319_01 baseado em Oracle jdk8u161-b12

to:
Versão build: 8.0.7.10
I wonder if you have no problem using this new version of build  8.0.7.10?

Thanks,


Comments
Kenny Smith commented Jan 13 '23, 11:18 a.m.

 Why not upgrade your RTC instance to 7.0.2 SR1?  


Rodrigo Guedes Costa commented Jan 13 '23, 11:36 a.m.

The company preferred not to upgrade by business strategy (will migrate to Gitlab) 

2 answers



permanent link
Daniel Moul (4.9k1318) | answered Feb 01 '23, 4:14 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

There are technotes available at ibm.com/support explaining how to upgrade the Liberty and Java for embedded Liberty deployments (I assume that's what you are using). It's likely (but not guaranteed) that you can use later Java 8 fix packs. We test this scenario with the latest Jazz (ELM) release; it's been a long time since we tested this with 6.0.6, so you will definitely want to try this is a test environment first.


permanent link
Rodrigo Guedes Costa (255) | answered Feb 02 '23, 7:13 a.m.

 Hi Daniel, thanks for the information.

We don't use Liberty.
We use WebSphere Application Server WAS 8.5.5 and have already successfully updated Java on it.
My doubt is about updating in the application folder /opt/IBM/JazzTeamServer_606/server/ ?
Thanks again.


Comments
Ralph Schoon commented Feb 02 '23, 7:18 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

There is documentation about upgrading. Follow that documentation. 


 The statement updating in the application folder /opt/IBM/JazzTeamServer_606/server/ does not make any sense to me. I believe the Java Version provided by WAS is the Java version the apps will run.


Rodrigo Guedes Costa commented Feb 06 '23, 6:08 a.m.
Hi Ralph, I was also thinking about this, I believe the application uses the java of WebSphere.
I'll test it on the test server.
that this version already meets us. 

Your answer


Register or to post your answer.