It's all about the answers!

Ask a question

Incompatible JVM with RTC 6.x Extensibility Instructions


Diane Durham (1634) | asked Nov 19 '21, 11:09 a.m.

 I'm following the instructions from the "Engineering Workflow Management Extensions Workshop".  In there follow the link to "Download files for versions 6.0.3 and later".  The PDF for "IBM Rational Team Concert 6.x Extensibility" has precise steps in Lab 1 on what to download and how to install what is needed to "Setting up the IBM Rational® Team Concert (RTC) SDK".  I followed everything step for step, but it doesn't work!  Help!


I am at step 14.  I'm trying to start the Eclipse after configuring it exactly as documented.  I get the error "Incompatible JVM. Version 1.8.0_161 of the JVM is not suitable for this product.  Version 11 or greater is required". 

So I followed the troubleshooting steps (which are actually in step 13 not step 14) and download the IBM Java.  I point to it and that doesn't work either.  Anybody know what version of java works with this lab and where to get it?

And Wow!  I just want to use the RTC CLI.  This is quite the process.

Accepted answer


permanent link
Diane Durham (1634) | answered Nov 19 '21, 1:49 p.m.

 I found out that eclipse v 4.22M (eclipse-SDK-4.22M3-win32-x86_64) does not work, so make sure to get 4.4.2.  I grabbed eclipse-standard-luna-SR2-win32-x86_64 and it works.

Ralph Schoon selected this answer as the correct answer

One other answer



permanent link
Ralph Schoon (60.5k33643) | answered Nov 19 '21, 1:03 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Nov 19 '21, 1:04 p.m.

 If you want to execute the EWM Extensions Workshop, please use an Eclipse version lower than version 4.16. E.g. use Neon. Newer Eclipse versions require Java 11 and I have not tested this. You can also use an RTC Eclipse Client that is shipped with the version as zip file. that works as well. 


The Extensions Workshop is for using the SDK (and develop Plain Java Client Library based tools). To use the RTC SCM CLI, there is no need to run this workshop. 

If you mean the Workitem Command Line, you can run a released version without the workshop. Only if you want to develop or debug it, you should run at least Lab 1 of the workshop to get a development environment set up.


Comments
Diane Durham commented Nov 19 '21, 1:51 p.m.

Thank Ralph.  I tried to find specific instructions on how to install and configure RTC SCM CLI and everything points to the workshop.  Where are instructions to just install and use the CLI or the WCL?

 


Ralph Schoon commented Nov 19 '21, 2:26 p.m. | edited Nov 19 '21, 2:41 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

There should be no reference for the SCM CLI to require the extensions workshop. 

See https://www.ibm.com/docs/en/elm/7.0.3?topic=reference-source-control-command-line for how to use it. It should be installed in the server. 

Otherwise download the installation manager repository or the plain zip file (scm tools in the Plain Zip section of https://jazz.net/downloads/workflow-management/releases/7.0.2?p=allDownloads). With the IM repository use IBM Installation Manager to installit. With the Plain Zip, just unzip it. Make sure Java is available. You can do advanced settings in the scm.ini. Then see the reference above. 


Ralph Schoon commented Nov 19 '21, 2:27 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

If you mean WCL like https://github.com/jazz-community/work-item-command-line then you should consider doing Lab 1 of the extensions workshop. 


Diane Durham commented Nov 19 '21, 2:51 p.m.

Thank you Ralph. The documents link to other documents which link to other documents.  But I think I found what I need without having to get the lab setup.  Appreciate you!

 


Ralph Schoon commented Nov 19 '21, 6:09 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

We are aware of the gaps and try to address them. Does not always work, but we are trying. 8) Good luck Diane! 

Your answer


Register or to post your answer.