It's all about the answers!

Ask a question

RTC-scmTools-Linux64-6.0.2.zip does not working on Ubuntu 18.04 LTS 64 bit system


Muhammad Fareed (11) | asked Jun 16, 2:12 p.m.

Hi,

I am trying to run the scmtools on my linux machine and have been running into some issues.
I downloaded the RTC-scmTools-Linux64-6.0.2.zip package from the IBM downloads website and unzipped it on my linux system. I need to run the lscm command located in the following path "/jazz/scmtools/eclipse"
I made some changes in the scm.ini, scm.sh, and scm files in order to change the java paths to point my local directories. I also commented out some of the -X lines as suggested in the command line read me text file. But now when I run ./lscm nothing happens. I then try running ./scm and get the following response:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.eclipse.osgi.internal.baseadaptor.BaseStorage                                    (file: .../rtc_scm/jazz/scmtools/eclipse/plugins/org.eclipse.osgi_3.6.50.R36x_v20120315-1500.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of org.eclipse.osgi.internal.baseadaptor.BaseStorage
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Scm:
An error has occurred. See the log file

The log file has the following messages:

!SESSION 2021-06-16 18:01:21.181 -----------------------------------------------
eclipse.buildId=unknown
java.version=11.0.11
java.vendor=Ubuntu
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data @noDefault

!ENTRY org.eclipse.equinox.common 4 0 2021-06-16 18:01:21.440
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.common_3.6.0.v20100503 [1]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4
        at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)
        at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)
        at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)
        at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
        at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

!ENTRY org.eclipse.update.configurator 4 0 2021-06-16 18:01:21.442
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.update.configurator_3.3.100.v20100512 [2]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3
        at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)
        at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)
        at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)
        at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
        at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

!ENTRY org.eclipse.core.runtime 4 0 2021-06-16 18:01:21.442
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.core.runtime_3.6.0.v20100505 [3]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3

Can someone please assist me with this issue?

3 answers



permanent link
Shashikant Padur (4.2k27) | answered Jun 17, 12:14 a.m.
JAZZ DEVELOPER

You are using java 11 which is not supported with 602 client. I believe RTC-scmTools-Linux64-6.0.2.zip came with a bundled jre and the scm.ini points to that jre which should work out of the box.


Comments
Muhammad Fareed commented Jun 17, 8:29 a.m.

 Hi Shashikant,


Thank you very much for getting back to me. I actually tried just running the lscm command out of the box but it did not work for some reason. I will do a clean reinstall (delete all files and unzip again) and try to run the lscm command. I'll post the error that I get here. 


permanent link
Muhammad Fareed (11) | answered Jun 17, 10:56 a.m.
I removed all the previous files and unzipped the rtc 602 zip file again. I just went into the eclipse folder and executed the lscm command using ./lscm. But I got the following error

.../jazz/scmtools/eclipse# ./lscm
Unrecognized option: -Xshareclasses:nonfatal
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Scm:
JVM terminated. Exit code=1
/usr/bin/java
-Xmx512m
-Xshareclasses:nonfatal
-Xquickstart
-Dosgi.requiredJavaVersion=1.6
-Xdump:system:events=systhrow,filter=java/lang/OutOfMemoryError,request=exclusive+prepwalk
-Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true
-jar .../jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher .../jazz/scmtools/eclipse/scm
-name Scm
--launcher.library .../jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.2.R36x_v20101019_1345/eclipse_1310.so
-startup .../jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-exitdata b
-data @noDefault
--config /root/.jazz-scm daemon start
--connection-timeout 120000
--inactive-timeout 7200000
-vm /usr/bin/java
-vmargs
-Xmx512m
-Xshareclasses:nonfatal
-Xquickstart
-Dosgi.requiredJavaVersion=1.6
-Xdump:system:events=systhrow,filter=java/lang/OutOfMemoryError,request=exclusive+prepwalk
-Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true
-jar .../jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar


Comments
Shashikant Padur commented Jun 17, 11:55 p.m.
JAZZ DEVELOPER

I see that the java is being picked up from /usr/bin/java. Can you paste the output of /usr/bin/java --version? If I remember correctly, 602 client supports java 7.

If the version of java is correct, then try removing the flags -Xshareclasses:nonfatal and also -Xquickstart (if that is also unrecognized).

Does the scm.ini have a -vm option in it?


Muhammad Fareed commented Jun 18, 9:35 a.m.

This is the result of the java version

.../usr/bin/java --version
openjdk 11.0.11 2021-04-20
OpenJDK Runtime Environment (build 11.0.11+9-Ubuntu-0ubuntu2.18.04)
OpenJDK 64-Bit Server VM (build 11.0.11+9-Ubuntu-0ubuntu2.18.04, mixed mode, sharing)

I will try installing java 7 and running the lscm command again


permanent link
Muhammad Fareed (11) | answered Jun 18, 11:26 a.m.

Hi Shashikant,


I download jdk 7 from oracle and placed in a local directory inside the usr folder. I modified the lscm executable. I just changed line 27

lscm line 27:
/usr/openjdk7/jdk1.7.0_80/bin  $EXTRA_JAVA_OPTS -classpath ....

I also edited the scm.ini file as follows:

# Uncomment following 2 lines to configure JRE.
-vm
/usr/openjdk7/jdk1.7.0_80/bin
-startup
plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.2.R36x_v20101019_1345
--launcher.suppressErrors
-data
@noDefault
-vmargs
-Xmx512m
#-Xshareclasses:nonfatal
#-Xquickstart
-Dosgi.requiredJavaVersion=1.6
-Xdump:system:events=systhrow,filter=java/lang/OutOfMemoryError,request=exclusive+prepwalk
-Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true
~

Now when I run the command I get the following error:

Unrecognized option: -Xdump:system:events=systhrow,filter=java/lang/OutOfMemoryError,request=exclusive+prepwalk
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Scm:
JVM terminated. Exit code=1
/usr/openjdk7/jdk1.7.0_80/bin/java
-Xmx512m
-Dosgi.requiredJavaVersion=1.6
-Xdump:system:events=systhrow,filter=java/lang/OutOfMemoryError,request=exclusive+prepwalk
-Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true
-jar .../jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher .../jazz/scmtools/eclipse/scm
-name Scm
--launcher.library ...jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.2.R36x_v20101019_1345/eclipse_1310.so
-startup .../jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-exitdata f
-data @noDefault
--config /root/.jazz-scm daemon start
--connection-timeout 120000
--inactive-timeout 7200000
-vm /usr/openjdk7/jdk1.7.0_80/bin/java
-vmargs
-Xmx512m
-Dosgi.requiredJavaVersion=1.6
-Xdump:system:events=systhrow,filter=java/lang/OutOfMemoryError,request=exclusive+prepwalk
-Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true
-jar .../jazz/scmtools/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar

I am still not sure what I am doing wrong


Comments
Shashikant Padur commented Jun 21, 1:03 a.m.
JAZZ DEVELOPER

You also need to remove the -Xdump option. Basically these options are supported by the IBM JRE and may not be supported by other JRE's.

Your answer


Register or to post your answer.