It's all about the answers!

Ask a question

Eclipse failed to connect to remote VM when Launching Debug Liberty Profile


Marcelo Bilezker (193) | asked May 16, 5:45 p.m.

 I am following instructions from the file named as: 


In Eclispe, after following all the instructions, i got "‘Failed to connect to remote VM. Connection refused.’ when running debug. 
JazzTeam server is up.
What is VM and how can i connect to it?

saw at: https://rsjazz.wordpress.com/2016/02/04/running-the-rtc-extensions-workshop-with-rtc-6-0-x/  a similar question, but he was oriented to check workshop articles, and no solutions are given there.  

Any clue what can be the problem or how to fix it?

2 answers



permanent link
Ralph Schoon (58.2k23642) | answered May 17, 2:09 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
For this to work, it is necessary to
  1. Successfully follow 1.2 and especially make sure the server.startup file is modified
  2. Stop the server and start the server again with the parameter -debug, if it was not started with -debug. I will update the text to state this. This was not necessary in the past, but now it is.

Comments
Ralph Schoon commented May 17, 2:15 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Java runs a virtual machine, called VM.


Marcelo Bilezker commented May 18, 3:27 p.m.

Thanks 

 I did what you say but still not running ( I did it also the first time, section 1.2 and run server with -debug option as well)

So, I decided to configurate eclipse again. At the document, I get to item 26, that says:
26. Connect to the project area. 
__a. On the left, switch to the Team Artifacts view and click the Accept Team Invitation link.
"
But, 
I do not see any "Accept Team Invitation".
This is what I see:

RTC Extension Server Workshop [localhost]
Favorites (it is empty)
Feed
My Source Control
My TEam Areas (it is empty)
Work Item History (it is empty)

So, Where can i found the the Accept Team Invitation ??


permanent link
Ralph Schoon (58.2k23642) | answered May 19, 2:44 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited May 19, 2:58 a.m.
It makes no sense to try to Accept the Team Invitation again, as you already have setup the connection to the server and project area. (As shown in the workshop, the action to accept the invitation can be found in the the Team Artifacts view.)  Nothing you explain doing here is related to the step.
 

Skip Lab 1.5. it is not essential for the workshop.


  The connection is on a level that does not require anything else than the configuration for the port to be correct and the server being started. You can do the workshop without this lab. The lab only shows the connectivity, to drive home the point, that you can debug a live server ware you deployed a plugin you developed. I do not know what does not work for you. The only way to try to get this working, would be a video conference and it is just not important enough for that.

Only thing you could try is to remove the statement 

set WLP_DEBUG_SUSPEND=n

Then start the server in debug mode again. The server should stop starting immediately and only start when you connect. If this does not work, make sure to check if the Port 8000 is already taken and change the port in the liberty.server.bat and in the launch you use to connect to the remote server.

Your answer


Register or to post your answer.