It's all about the answers!

Ask a question

V7.0 RM upgrade never completes


Francis Kemp (7212334) | asked Jun 25, 12:21 p.m.
Upgrading a small Jazz Sandbox environment from V6.0.6 iFix016 to V7.0.0 iFix002 on Win 2016 in preparation for upgrading the Jazz production environment next month. This Sandbox does not have LDE or LDX and is on a single server. The RM database size is about 6GB.

I'm following Option 3 here: https://jazz.net/wiki/bin/view/Deployment/MigratingTheRequirementsManagementLinkValidityData.  The addTables command works OK until it gets prints this line:

Finished collecting database statistics for schema REPOSITORY.

and then it just continues to run with no further output.  It's been running for 2 days now. 

In looking at the instructions, I found that I forgot this step:

Faster upgrade and indexing

To ensure your Requirements Management application upgrade and indexing during product runtime completes faster, it is recommended to apply ELM 7.0 iFix001. After applying the ELM 7.0 iFix001, make sure you update the teamserver.properties file for RM by adding com.ibm.team.jfs.reindex.all.by.storageArea=true .
For more information, see Work Item 499982.

Could that be causing this problem?  Has anyone else seen anything like this?

Thanks,
Fran Kemp

One answer



permanent link
Ian Barnard (408610) | answered Jun 25, 6:17 p.m.
JAZZ DEVELOPER
edited Jun 26, 3:55 a.m.

Hi Fran


If you're using config management in 6.0.6.1 then you must only upgrade with >=iFix001 already installed. You say you're upgrading to iFix002, but I guess you didn't do the extra step of editing teamserver.properties. You'll have to redo the complete migration from a full restore.

What database are you using? I've seen Derby take a very long time at this step - well, I call six hours for a tiny demo environment on Derby a very long time - so you'll have to be very patient, let it run. Yes it doesn't indicate progress, but as long as the Java process is showing some activity then it's doing something.

HTH
Ian


Comments
Francis Kemp commented Jun 26, 1:15 p.m.
Hi Ian,

In this Sandbox environment, we have GC installed but there are no configurations being created.  In fact, the "repotools-rm exportLinkValidity" command created 0 rows in the output CSV file.

We are using DB2 V11.1.4.5.  The size of this RM database is about 6GB so it's not a major problem to restore the database from backup and start over.

We are upgrading from V6.0.6 iFix016 to V7.0.0 iFix002 - does this change any of your suggestions above?

Thanks for the feedback,
Fran


Ian Barnard commented Jun 26, 1:40 p.m.
JAZZ DEVELOPER

The best thing to do is to create a support case :-)


Francis Kemp commented Jun 26, 5:20 p.m. | edited Jun 26, 5:43 p.m.
Created one of those before coming here. :)

Support had never seen this issue - I thought someone here might have.


Your answer


Register or to post your answer.