It's all about the answers!

Ask a question

RPE - printModuleBook - Skip attributes for headings


1
1
Glyn Costello (876) | asked May 18 '20, 1:46 p.m.
 Hi, 

New to RPE, in the printModuleBook template which comes with the publishing service, how can I modify the "-Content" section of the DTA to skip over the printing of attributes if the artifact type is a "Heading"? 

Accepted answer


permanent link
Subramanya Prasad Pilar (4.4k14) | answered May 19 '20, 12:20 p.m.
edited May 19 '20, 1:07 p.m.
Hi Glyn,
printModuleBook template uses views data source schema and you will not find isHeading attribute. You should rather check if the div attribute value contains heading tag. Use an internal variable (_isHeading) and set its value to true or false based on this check.

For the table that shows the attributes, you can apply the following condition so that it will be skipped for headings:

showAttributes == "true"  && _isHeading == "false"

Glyn Costello selected this answer as the correct answer

2 other answers



permanent link
Sean F (1.3k22563) | answered May 18 '20, 3:10 p.m.
edited May 18 '20, 3:11 p.m.
Hi Glyn,

Not sure about your template specifically but in general you should be looking for or creating a container with context:- datasource/artifact/moduleContext/contextBinding

You should be looking for a property in that context called 'isHeading' and setting a condition on that property to false to avoid heading artifacts in the loop




permanent link
Bartosz Chrabski (3.2k12141) | answered May 18 '20, 4:30 p.m.
edited May 19 '20, 1:24 p.m.

 Glyn,


As Sean wrote, you shoud use isHeading attribute but it will only work for printModuleTable but wont work for printModuleBook.

You can filter using atrifact type artifact type in rpe report. 

Your answer


Register or to post your answer.