It's all about the answers!

Ask a question

Why is the preconditon "Require-Work-Item-to-Match-Query" only working for me in child project areas?


Bob Ferguson (8722) | asked May 13, 10:21 a.m.
edited May 17, 8:19 a.m.
 I am currently using RTC 6.0.5.
I have gone into a parent project and set the Require-Work-Item-to-Match-Query precondition.
The following were the steps I did:
1. In the parent process area I created a query "Find WI Type Task".
2. I shared that query so that it now resides in the Predefined Queries of the shared process area.  
3. In the shared process area I went to the Deliver (server) in Operations Behavior and in the Everyone column I added the precondition require Work Items to Match Query.
4  I then selected the Find WI Type Task as my query.
5. For each change set: I selected All work items must match.
6. Work items from other project areas are:  I selected Allowed.
7. When query is from a different project area: I selected run query in this project area.
8. I applied the changes and save the process work area. 

I then tested if I could check in and deliver associating with a Story and then tried associating with a Task.
It did not work for a Story but did work for a Task.  This is exactly what was supposed to happen.

When other users tried the same thing the received the following error:

CRJAZ1316E The user "1405448790@mil" does not have permission to read item "_il9NoGwXEem-Zu3RlQOFAA", which has the "QueryDescriptor" item type.

I am assuming that the other users do not have permissions to read/execute the query.
If this is the case, how do I give them permissions?

If not, what else would cause this problem?

Be the first one to answer this question!


Register or to post your answer.