It's all about the answers!

Ask a question

Some links show up in DNG but not in JRS


Sean F (1.3k22788) | asked Dec 15 '18, 3:31 p.m.
Does anybody ever experience that some links show up in DNG and in JRS but some other links, created at the same time and of the same type, show up in DNG only but not in JRS?

We have created many links using Link By Attribute.

All of the links show when using a DNG traceability view but some of the links (a small percentage) do not show when running JRS traceability reports.

We are using DW not LQE but data refresh is not the issue. The issue remains even after refreshing the metadata and the data.

I also tried manually deleting and manually recreating one of the problem links and then running DCC refresh but this did not resolve the issue.

Has anyone encountered anything similar and was there any resolution?

4 answers



permanent link
Davyd Norris (1.7k112) | answered Dec 15 '18, 6:15 p.m.
Hey Sean,

What type of links are you creating? Global or Module local links? Are the artefacts in several modules? Are the missing links between artefacts that are in different modules, or a sub/superset of modules compared to the others?

I'm currently trying to track down some JRS behavior that seems to be due to artefacts simply being in one more or one less module than others. In one case, a report that was working fine stopped working when artefacts were reused in a new module. This is obviously not cool!

permanent link
Sean F (1.3k22788) | answered Dec 16 '18, 3:00 a.m.
edited Dec 16 '18, 3:05 a.m.

 Hi Davyd,


The links in question are actually the 'Child Of' links which you suggested, for supporting concatenation of hierarchically defined requirements, on another thread I started.

All the links have been created using Link By Attribute (using the exported parentBinding attribute re-imported to the 'Link By Attribute' attribute.

All links were created at the same time and in the same way and are Base Artifact links. All of the artifacts appear in only one module and were created by Word Import.

All the links show up in a DNG traceability columns but some (about 10%) do not show up in a JRS report.

I tried manually breaking and re-creating one of the bad links (and then doing a DCC refresh) but this did not resolve the problem).

Very strange.


Comments
Davyd Norris commented Dec 16 '18, 3:27 a.m.
OK so now look to the artefacts themselves.

Are the artefacts that are causing problems in a Collection or a Module? Are they in a different or additional Collection or Module compared to the ones that work? Are they NOT in a Collection or Module when the others are?

If you used the parentBinding column then you will quite likely also have created Parent Child links between Heading and Information artefacts. Have you selected these in your JRS report? Are the missing links to different artefact types?

These are all things I've found that can cause problems while playing with JRS

Sean F commented Dec 16 '18, 1:23 p.m.
The module contains only Headings and Technical Requirement artifacts.

All were imported from a Word doc.

The artifacts all exist in one module only and there are no collections.

Hierarchy was imposed on the Tech Reqs to reflect hierarchical req statements.

Child Of links were created using Link By Attribute only between parent/child Tech Reqs, not from Tech Reqs to Headings.

This worked fine in a previous module with no JRS errors.

This time I have 10% of the links not showing JRS.

Manually deleting and recreating the links does not help so it would appear to be a problem with the artifact rather than the link.

My next test will be manually duplicate one of problem artiacts and manually link it. If that works I will just fix up the issues manually.

I might also try archiving and restoring the project via a template to see if the restored copy resolves the issue.

Davyd Norris commented Dec 16 '18, 3:50 p.m.
The other thing worth a try is a full data load in the DCC, but yes I would look at the artefacts themselves.

Try removing the link in the report and making sure the left hand side of the join is all there, then add the link back in a very simple join. Also try building a report going the other way to see if the problem with the links is directional

permanent link
Ulf Arne Bister (1.3k113) | answered Dec 17 '18, 4:16 a.m.

 Sean,

could you please share CLM Version, iFix Level and preferrably Server OS and DB Vendor for your infrastructure? Just to make certain we can pin point better.

Thanks,
Arne


permanent link
Sean F (1.3k22788) | answered Dec 18 '18, 11:30 p.m.
Hi Ulf,

CLM 606 iFix 3 Cloud provisioned by IBM SaaS

Getting some very strange results.

The DNG filter tells me that there 774 links in the artifacts in this module.

The JRS report only shows 403 links

I make a template copy of the project and then instantiate a copy of the project from the template

The DNG filter still says that there are 774 links in the copy

I copy the JRS report and change it to report on the copied project. Now the copied JRS report says that there are 691 links in the copied project

So the identical duplicate data and identical duplicate report are not only wrong but inconsistently wrong.

Comments
Davyd Norris commented Dec 19 '18, 12:08 a.m.

Did you try the full data load in the DCC?


Sean F commented Dec 19 '18, 12:55 a.m.
Hi Davyd,

I tried running the reverse query as you also suggested (Parent Of) and the results are identical 403 links. So it is not directional.

I will have to wait untill after hours to try the full DCC load.

The Delta jobs are configured to run every hour. The full load might take a while so I might just confirm with support that there is no risk of a clash, although I read on another thread that Delta jobs will not try to run while a full load is running.

Sean F commented Dec 19 '18, 9:17 a.m.

The DCC full load just finished.

It took 3.5 hours.


The JRS situation has got worse instead of better.

Now the real project is only showing 157 links instead of 403 out of the 774

The second copy is only showing 357 links instead of 691 out of the 774.


Sean F commented Dec 19 '18, 7:38 p.m.

Also the 1st 5 links in the new report, after the full load, were actually not showing in the report before the full load.

74140, 74141, 74142, 74143, 74144

So that would seem to indicate that it is not a prblem with the data itself.


Your answer


Register or to post your answer.