It's all about the answers!

Ask a question

OSLC throws null pointer exception while fetching the test case from RQM.

Anurag Patel (21568) | asked Apr 13 '18, 3:15 a.m.

 I have two RQM instances installed on two different servers lets assume server A and B. If I tried to fetch test case from server A, I succeed. But with same code while I tried to fetch test case from server B my code gives null pointer exception. Please note I double check with test case id which is present in both. Please help me to understand the actual problem and What can possible to do for resolving problem

Don Yang commented Apr 13 '18, 4:11 a.m.

what commands you used to fetch testcase from server A and B and whether the exception has more trace, what is your QM version?

Anurag Patel commented Apr 13 '18, 9:23 a.m.

 Thanks Don, 

I am using same OSLC query to fetch test case from RQM. I my both servers has version of 6.0.2. But server A responds correctly but server B failed to retrieve test case 

One answer

permanent link
Paul Slauenwhite (8.4k12) | answered Jun 26 '18, 1:25 p.m.

It's difficult to determine the cause without the stack track in the RQM log or the error message in the HTTP response.  

Please open a RQM defect ( with this information and we'll investigate.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.