It's all about the answers!

Ask a question

RTC Client Plug-in v5.0.2 and Server 6.0.3 compatiblility

Ryan McFadden (191215) | asked Feb 26 '18, 6:00 p.m.

I am working through the Lab Exercises for creating server extensions.  I am attempting to setup my development environment to match our production environment.  We have the 6.0.3 version on our production servers but we are still using the Client Plug-in v5.0.2. 

When I launch the server using the server.startup script in Linux, I can view the server in Firefox through the web interface.  When I attempt to establish a connection through Eclipse however, I get the following error message:

CRJAZ1371E: The following URL cannot be reached: https://localhost:4993/ccm/versionCompatibility?clientVersion=5.0.2.  The server cannot be reached.  The network could not connect to the server.  Connection refused.

Is there something I need to configure on the server to allow a connection from a previous version of the client?

Accepted answer

permanent link
Ralph Schoon (62.7k33643) | answered Feb 27 '18, 2:33 a.m.
edited Feb 27 '18, 2:35 a.m.

Please read

In general you want to have the Plain Java API and the SDK on the same version as your server environment.
5.0.2 should work with 6.0.x, but there are a reasons why you don't want to just stay with this. One is that backward compatibility can have performance impact.

However, I don't believe that is the issue here. The problem might be the URL or port. The very strange port number 4993 might be contributing.
Regardless, please upgrade the client API to the server version.

Ryan McFadden selected this answer as the correct answer

Ryan McFadden commented Feb 27 '18, 12:44 p.m. | edited Feb 27 '18, 12:57 p.m.

We have plans to upgrade the client in the future.  Currently we have some compatibility issues that prevent us from upgrading at this time.  After posting I found the advanced server setting that specifies the minimum client version and it is set to 5.x. 

I found the issue.  In the team invitation I was using the port number of 4993 instead of 9443. 

Your answer

Register or to post your answer.