It's all about the answers!

Ask a question

RTC Build fails by throwing error as already loaded from a different location


sanjeev d (11) | asked Oct 25 '17, 2:25 a.m.
edited Oct 31 '17, 9:51 a.m. by David Lafreniere (4.3k7)

Hi,

I am taking over build (build definition/workspace) ownership from one of our team members. As part of it, our team member tried transferring the build's Workspace ownership to me but with this change the build fails by throwing errors as shown below. With our team member (from whom I am going to take over the ownership) as the owner of the workspace, build works fine. So, could some one please let us know the procedure/steps to be followed while changing the build definition/workspace ownership?


Thanks,
sanjeev


Comments
Ralph Schoon commented Oct 25 '17, 2:50 a.m. | edited Oct 29 '17, 6:02 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The workspace is supposed to be owned by the user that runs the build engine - as it tells you in the build definition.
The user that runs the build engine is usually a technical user that has a Build license assigned. It can be a normal user, but it is a lot easier to use a technical user - so that you don't have to change the user if the responsible people change.

In addition to having the license the build user needs to be member of any project area they have to build for and have access to the SCM data.

There is not usable error information accessible in your question.


sanjeev d commented Oct 25 '17, 4:47 a.m. | edited Oct 29 '17, 6:02 p.m.

Hi Ralph,
       I run the build engine and I own the build workspace. I am a member of the Project Area , can create a new build definition and I have a build server's login user-id. Some time back (around 2 years back) I used to own 1 build definition and later I transferred to one of our team members. That time it was pretty straight forward and was done by transferring the ownership on the build workspace to the new owner or so. So, I hope for me there shouldn't any issues related to access.

Now the build definition that I created is deprecated. And 4 new build definitions (for four different streams) are created by one of our team members and he is trying to transfer ownership on those new 4 build definitions to me. Please check the below details for command the we use to run the build engine and errors in the build log file.

Command to run start engine:
% /usr/java7_64/jre/bin/java -jar /opt/IBM/RTC/CLM_6.0.3_Build/jazz/buildsystem/buildengine/eclipse/plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar -repository https://igartc03.swg.usma.ibm.com/jazz -userId abcd@in.ibm.com -passwordFile /net/rpo-fs015/vol/homes/xxxxxx/password.txt -engineId xxxxxbldengine
2017-10-25 03:07:12 [Jazz build engine] Running build loop...
2017-10-25 03:07:12 [Jazz build engine] Waiting for request...

Warning when a new build is requested:
2017-10-25 03:09:16 [Jazz build engine] Found a user request for build definition "DEV-XXX build".
Oct 25, 2017 3:09:23 AM com.ibm.team.filesystem.client.internal.LoggingHelper log
WARNING: Status WARNING: com.ibm.team.filesystem.client code=0 Problem detected: your filesystem supports symlinks but you are missing the Eclipse native support for them null

Error from the build log file:
[Jazz build engine] Fetching files to fetch destination "/net/rpo-fs015/vol/homes/XXXbld/devXXXBuilds" ...
com.ibm.team.build.internal.scm.SourceControlUtility$2: Status ERROR: com.ibm.team.filesystem.client code=2 Loading the directories in the file system would overwrite/remove existing directories. null children=[Status ERROR: com.ibm.team.filesystem.client code=0 /XXXRestAPI [Development XXX Stream - Dev Build Workspace - XXX Main] (already loaded from a different location) null
    at com.ibm.team.build.internal.scm.SourceControlUtility.updateFileCopyArea(SourceControlUtility.java:783)
    at com.ibm.team.build.internal.engine.JazzScmPreBuildParticipant.preBuild(JazzScmPreBuildParticipant.java:249)
    at com.ibm.team.build.internal.engine.BuildLoop.invokePreBuildParticipants(BuildLoop.java:1122)
    at com.ibm.team.build.internal.engine.BuildLoop$4.run(BuildLoop.java:888)
    at java.lang.Thread.run(Thread.java:798)
Contains : 0 /XXXRestAPI [Development XXX Stream - Dev Build Workspace - XXX Common] (already loaded from a different location)
Contains : 1 /XXXGui [Development XXX Stream - Dev Build Workspace - XXX Gui] (already loaded from a different location)
........
.......

Note: Same error (already loaded from a different location) is thrown for all the projects in that workspace.

Thanks,
sanjeev

Accepted answer


permanent link
Ralph Schoon (55.5k23642) | answered Oct 25 '17, 6:06 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

There seems to be a load conflict, where the load would overwrite data that is currently already been loaded.
Check the build load destinations and make sure they are empty. In the Build definition, Jazz Source Control check "Delete directory before loading".

Make sure that all repository workspaces are unloaded before loading them again e.f. in clients.

Otherwise I don't know what you would have done to cause the error.

Geoffrey Clemm selected this answer as the correct answer

Comments
sanjeev d commented Oct 26 '17, 5:08 a.m. | edited Oct 29 '17, 6:02 p.m.

Thanks Ralph,
In the Build definition, under Jazz Source Control tab, selecting the check box "Delete directory before loading" fixed the issue.

Thanks,
sanjeev

Your answer


Register or to post your answer.