It's all about the answers!

Ask a question

RPE / DNG: Bad number of artifacts reported


Giuseppe Rotondi (111) | asked Oct 04 '17, 6:02 a.m.

Dear all,

I have an issue with the generation of a document form RPE. The RPE template (I'm using the standard DNG Module template) is connected to a DNG module, and when I generate the report form RPE only the first 10 artifacts are estracted from the DNG module (it contains 60-70 artifacts).

SW versions:
Rational DNG 6.0.2 (iFix011)
IBM Rational Publishing Engine Document Studio 2.1.2

DNG module link:
https://server-name:9443/rm/resources/_429efa2361da429fbf2d83cf6dc2b508?oslc_config.context=https%3A%2F%2Fdoors-ng.angeloinv.net%3A9443%2Frm%2Fcm%2Fstream%2F_oLG5ZoceEeeZ2-qsVveOxw

RPE URI:
https://server-name:9443/rm/publish/modules?resourceURI=_429efa2361da429fbf2d83cf6dc2b508

RPE Report:

Modello Spec Fun_Rev 05.doc

Modello Spec Fun_Rev 05.doc............................................................................................................. 1

Introduzione.......................................................................................................................................... 3

Documenti Allegati........................................................................................................................... 3

Documenti di Riferimento................................................................................................................ 3

Normative di Riferimento............................................................................................................. 3


No table of figures entries found.

Introduzione (1st artifact)

Documenti Allegati

Documento allegato 1

Documento allegato 2

Documento allegato 3

Documenti di Riferimento

Normative di Riferimento

I documenti devono essere inseriti attraverso un link alle risorse utente contenute nei moduli della cartella “02_Documenti Generali”

Normativa 1

Normativa 2 (10th artifact)


Thanks,
Giuseppe

One answer



permanent link
Subramanya Prasad Pilar (4.6k16) | answered Oct 04 '17, 6:40 a.m.

Did you click "Preview Document" or "Generate Document"? For preview, RPE uses 10 results by default (which can be changed in Preferences -> RPE -> Engine Preferences) and hence first 10 artifacts are shown in the output.


Comments
Giuseppe Rotondi commented Oct 04 '17, 6:51 a.m.

Thank you very much, I'm new to RPE

Have a nice day,
Giuseppe

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.