It's all about the answers!

Ask a question

The Rational ClearQuest bridge in RTC 2.0


Rachel Wei (7692) | asked Sep 23 '09, 12:02 p.m.
Our team are trying to use the Rational ClearQuest bridge in RTC 2.0, but I got below message when select ClearQuest Records on the Rational Team Concert Web client toolbar after I finished configuring ClearQuest bridge in RTC. The ClearQuest Records view didn't open.

Our CQ web server was setup and used for long time, the version is 7.0.

What's the likely reason?

Error: Unable to load /jazz/cqweb/cqlogin.cq?action=Ping status:404
Either CQ Remote server is not configured or not available. Please contact administrator.

Thanks.

13 answers



permanent link
Rachel Wei (7692) | answered Sep 23 '09, 3:59 p.m.
Just took a look of our ClearQuest Web Server, the version is 7.0.1.0
Is it CQ 7.1 that required to work with ClearQuest Bridge?

permanent link
Mark Ingebretson (58515036) | answered Sep 24 '09, 8:43 a.m.
rwei wrote:
Just took a look of our ClearQuest Web Server, the version is 7.0.1.0
Is it CQ 7.1 that required to work with ClearQuest Bridge?


Yes, that is correct. The CQ Bridge requires ClearQuest be at version
7.1.x.

https://jazz.net/downloads/rational-team-concert/releases/2.0?p=news#cq-bridge

permanent link
Rachel Wei (7692) | answered Sep 24 '09, 11:12 a.m.
One more question? Dose CQ Connector require ClearQuest be at version
7.1.x ?


rwei wrote:
Just took a look of our ClearQuest Web Server, the version is 7.0.1.0
Is it CQ 7.1 that required to work with ClearQuest Bridge?


Yes, that is correct. The CQ Bridge requires ClearQuest be at version
7.1.x.

https://jazz.net/downloads/rational-team-concert/releases/2.0?p=news#cq-bridge

permanent link
John Vasta (2.6k15) | answered Sep 24 '09, 1:53 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
The CQ Connector can work with CQ 7.0.1 or later.

One more question? Dose CQ Connector require ClearQuest be at version
7.1.x ?


rwei wrote:
Just took a look of our ClearQuest Web Server, the version is 7.0.1.0
Is it CQ 7.1 that required to work with ClearQuest Bridge?


Yes, that is correct. The CQ Bridge requires ClearQuest be at version
7.1.x.

https://jazz.net/downloads/rational-team-concert/releases/2.0?p=news#cq-bridge

permanent link
Dave Hecker (6633) | answered Oct 05 '09, 11:09 a.m.
I'm in the exact same position. We have CQ 7.0.1 going and I want to integrate RQM with it, for simple defect tracking using our existing CQ system.

I can't decide if I should bother upgrading our CQ server to 7.1 or just try and use the connector product. The bride should be fine, and it seems much simpler but the upgrade to 7.1 seems like a pain.

The connector won't require a CQ upgrade, but it seems like much more of a 'deal' once it's set up.

Has anyone used both? Any advice or input on this one?

thanks! Dave

permanent link
Richard Piazza (381) | answered Oct 05 '09, 12:43 p.m.
JAZZ DEVELOPER
This depends upon many factors.

First, the CQ Bridge is much easier to set up than the CQ Synchronizer (nee Connector), but the bridge will give you little help if you want to eventually view your current CQ data in RTC.

Second, Rational is about to release CQ 7.1.1. The upgrade from 7.1 to 7.1.1 has been made much easier by using the IBM Installation Manager starting with 7.1. If you plan on upgrading CQ eventually, it might be a good time to start the move to CQ 7.1.x.

Third, depending upon the complexity of your CQ schema, it might be time-consuming to write synchronization rules for the CQ synchronizer . It comes with some example sync rules based on the OOTB Defect Tracking schema. If you schema is unlike that one, you would have more work to do to use the synchronizer.

Rich Piazza
Jazz CQ Connector team

permanent link
Dave Hecker (6633) | answered Oct 05 '09, 12:49 p.m.
This depends upon many factors.

First, the CQ Bridge is much easier to set up than the CQ Synchronizer (nee Connector), but the bridge will give you little help if you want to eventually view your current CQ data in RTC.

Second, Rational is about to release CQ 7.1.1. The upgrade from 7.1 to 7.1.1 has been made much easier by using the IBM Installation Manager starting with 7.1. If you plan on upgrading CQ eventually, it might be a good time to start the move to CQ 7.1.x.

Third, depending upon the complexity of your CQ schema, it might be time-consuming to write synchronization rules for the CQ synchronizer . It comes with some example sync rules based on the OOTB Defect Tracking schema. If you schema is unlike that one, you would have more work to do to use the synchronizer.

Rich Piazza
Jazz CQ Connector team


Hi -

Thanks for your comprehensive reply. We are in mid-project so we are fairly clear on the functionality we will likely need because the project will end within a year. That makes future upgrades less important, too.

I'm feeling like the bridge is the way to go, but the documentation for upgrading 7.0.1 to 7.1 is ambiguous - if we could upgrade the server but not the clients that would be great! Upgrading the clients on this distributed team would be really tricky, so I'm trying to avoid that.

Our schema isn't all that customized, but having to write sync rules, etc. could get cumbersome. I'm hoping for the bridge but I need to get some detail about the CQ upgrade first.

thanks again! Dave

permanent link
Sreedhar Rella (24178) | answered Oct 05 '09, 2:36 p.m.
JAZZ DEVELOPER
For CQ Bridge all you need is a ClearQuest v7.1 WebServer.

In your situation, you have to upgrade only ClearQuest Web server. You can point your new v7.1 CQ Web server to an existing CQ repository(DB). This will allow your existing CQ Native clients continue to work, also have a v7.1 Web Server for your CQ Bridge integration in RTC.

PS** do not upgrade CQ DB feature level during v7.1 upgrade. this will mandate an upgrade of every CQ Client. connecting to this DB.

Hope this helps.

-Sreedhar

permanent link
Dave Hecker (6633) | answered Oct 05 '09, 2:39 p.m.
For CQ Bridge all you need is a ClearQuest v7.1 WebServer.

In your situation, you have to upgrade only ClearQuest Web server. You can point your new v7.1 CQ Web server to an existing CQ repository(DB). This will allow your existing CQ Native clients continue to work, also have a v7.1 Web Server for your CQ Bridge integration in RTC.

PS** do not upgrade CQ DB feature level during v7.1 upgrade. this will mandate an upgrade of every CQ Client. connecting to this DB.

Hope this helps.

-Sreedhar


Very interesting - I hadn't realized it was possible to upgrade only the webserver! This sounds promising, thanks.

permanent link
The-Binh Le (3334) | answered Oct 06 '09, 12:03 a.m.
Does it mean the Web server 7.1.x should be used in read-only mode? Because I think a CQ DB for 7.0.1 cannot / should not be written into from a 7.1.x interface? Thanks.

Your answer


Register or to post your answer.