It's all about the answers!

Ask a question

Reuse a component whose Visibility is set via Access Group


Rainy John (381225) | asked Mar 09 '17, 7:40 a.m.

 Assume there is a Component C1 under a Project P1. I am not a member of P1.

Ownership of C1 is P1 and Visibility is given to a Access Group where I am a member.

I would like to add C1 to Project P2 where I am a member and I have all the permissions in P2.
I am able to add C1 to a stream in P2; but on save I am getting java.lang.nullpointerexception. 
But looks like, it is saved in P2 Stream with some weird behaviour.
When I open this Component from P2 Stream, I am getting the error "CRJAZ1319E Read access is not permitted. The user, <xxx> tried to read one or more items that have the following type: TeamArea


One answer



permanent link
Lily Wang (4.9k714) | answered Mar 09 '17, 8:46 p.m.

I had the same issue in RTC 6.0.3. There's no issue to browse the component's repository files from P2 stream. But when I tried to open the component  to browse the component's owner information the error was happened.
You may contact IBM Support to check if this is expected or a product issue.

Your answer


Register or to post your answer.