It's all about the answers!

Ask a question

Explore Project Button is not visible in localhost Web UI for RTC 5.0.2


Princi Verma (2811) | asked Jan 18 '17, 5:26 a.m.

 Hi,


I have done the setup for RTC 5.0.2 at my local using IBM RTC 4.X Extensibility pdf. And I have created one project area at my local 'https://localhost:7443/jazz' using Mozilla Firefox version 29.0 but in that project area Explore Project Button is not visible. So I am unable to create Work Item to test plugin from Web UI at local.

Please provide some valuable solution. Thanks!

Accepted answer


permanent link
Princi Verma (2811) | answered Jan 24 '17, 2:34 a.m.

 Hi,


I have done the setup again, now Explore Button is visible...

Thank you !  

Ralph Schoon selected this answer as the correct answer

3 other answers



permanent link
Ralph Schoon (59.7k23643) | answered Jan 18 '17, 5:49 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jan 18 '17, 5:51 a.m.
  1. The extensions workshop does not use the button "Explore Project"
  2. I can't see why the button should not be available, however there are other ways to get to a project area. You can for example use the home menu
     

Comments
Princi Verma commented Jan 18 '17, 5:58 a.m.

 Hi Ralph,


When I select the project area then it just shows the Overview of it and without Exploring the Project Area how can I create the Work Item through Web UI?


Ralph Schoon commented Jan 18 '17, 6:04 a.m. | edited Jan 18 '17, 6:04 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

2 I can't see why the button should not be available, however there are other ways to get to a project area. You can for example use the home menu


Princi Verma commented Jan 18 '17, 6:41 a.m.

I checked on Home menu but still I am unable to see the project area over there to explore it.


Ralph Schoon commented Jan 18 '17, 6:44 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Check the project area in the Eclipse UI, if you don't find it there, it does not exist. Or your Jetty based server is corrupt in which case you should rerun the JUnit test in Lab 1 and recreate the project area later.


Princi Verma commented Jan 18 '17, 7:43 a.m.

 ok thank you...


Princi Verma commented Jan 18 '17, 7:51 a.m.

 Actually I want to test one plugin in that when I add the attachment through eclipse then it doesn't show any error in adding the attachment but when I try to do the same on Web UI on production of RTC5 then it shows the error that "unable to add the attachment" .. so I want to test this plugin at my local but in the local in Web UI I am unable to explore the project area, due to this I am not able to create the work item from web UI, and if I test using eclipse to add the attachment then I am able to add it.


That's why I am asking this. It would be really helpful if you provide some solution for this.

Thank you !


Ralph Schoon commented Jan 18 '17, 8:17 a.m. | edited Jan 18 '17, 8:18 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

If you read your question, you will realize that there is no information at all, that could serve as a starting point why your Web UI does not show the button. I have quickly looked into the issue you talk about (the operation data giving back an attachment, instead of a work item state), and I had no such issue. The button was there, I was able to easily navigate in the web UI, create a work item and add an attachment. The version I used was 6.0.3 since I am currently updating the workshop for 6.0.3.

So the problem is basically your set up that you need to get fixed. e.g. create another project, add users, observe the log files etc to get it working.

showing 5 of 7 show 2 more comments

permanent link
anup Gaur (1391335) | answered Jan 18 '17, 12:05 p.m.

 I had a similar issue in my Jetty setup using rtc 6.0.2. To navigate just use the URL in the following format.


Replace the ProjectName with your Project Name (case sensitive). Hope this helps.


Comments
Princi Verma commented Jan 19 '17, 1:32 a.m.

 Hi Anup,


I tried your solution but still "Explore Project" is not visible.
thanks...


permanent link
Robert Wen (690212) | answered Jan 19 '17, 1:45 p.m.

 Is the account you're using a member of the project you want to explore?  


Comments
Princi Verma commented Jan 20 '17, 12:08 a.m.
Hi Robert,

Yes that account is the member of the project what I want to explore.

Your answer


Register or to post your answer.