It's all about the answers!

Ask a question

RTC to DNG links visibility in DNG is strange

Jan Komárek (174) | asked Jan 03 '17, 9:59 a.m.
retagged Jan 20 '17, 3:24 p.m. by Ken Tessier (84117)
Hello all,

I have requirement in DNG, stories and Defects in RTC. And I have links from stories (Implemented By) and links from deffects (Affected by) and I cannot see both links in Doors.

When I open module in which artifact is used and click on rewuirement and to see requirement links, I see implemented by, but not affected by.
When I open defect and go to requirement through link in defect, I see affected by link, but not implemented by.
When I go straight to artifact through search or browsing I see only affected by.
When I open links explorer, it allways shows just one link which is in the list.

I have no filters on link type and link type filter shows only that link type which is present in list.

Do I have something wrong in setup, or is it a Defect?

Thank you all in advance for your help,

Daniel Moul commented Jan 03 '17, 10:07 a.m.

Do you have configuration management enabled in DOORS NG?

Jan Komárek commented Jan 03 '17, 12:01 p.m.

No I don't.

Accepted answer

permanent link
Donald Nong (14.5k414) | answered Jan 09 '17, 12:12 a.m.

Nothing is really wrong and you just need to understand the difference between a "module artifact" and a "base artifact". In your case, the one with the Implemented By link is the module artifact, and the one with the Affected By link is the base artifact. It is a bit confusing as they look the same, but if you check the resource URI, you can see that they're different. Also, if you expand the Overview section, you can easily tell which one is a module artifact (with module information shown in the section), and which one is not (without module information). The easiest way to solve this confusion is select the "include links, tags and comments from the base artifacts" option - the first icon in the top right menu bar. For more information, see

Jan Komárek selected this answer as the correct answer

Jan Komárek commented Jan 12 '17, 7:53 a.m.

 Thank you very much, now it makes sense.,

Your answer

Register or to post your answer.