It's all about the answers!

Ask a question

RTC - GitHub Enterprise integration: cannot set time spent on GitHub's side.


Maria Victoria Martinez Torino (14923455) | asked Oct 18 '16, 2:26 p.m.
Hi,

I have an RTC project area integrated with a repository in GitHub Enterprise (GHE). The integration was done following the instructions in http://www.ibm.com/support/knowledgecenter/en/SS2L6K_6.0.1/com.ibm.team.connector.cq.doc/topics/t_git_hub_ent_commit_linking.html .
I created a commit change in the GHE repository, entered a comment mentioning the work item type and work item ID and the time spent. This was done following the instructions in the image shown at the bottom of this page: https://jazz.net/products/clm/features/clm_integrations.
The problem is that only the work item status was updated on RTC's side. Time spent attribute remains blank and the update in time attribute is not reflected in my RTC project.

Could you please tell me if I am missing something or misunderstanding something? OR is there any bug in the RTC application not allowing to recognize the syntax being used on GHE's side?

Thanks,
Vicky.

Additional information:
- RTC's Project area is based on the Scrum template and has some minor customization but nothing impacting work items' configuration.
- RTC's Project area is in a server running on jazz 6.0.1 iFix003 platform.

One answer



permanent link
Shubjit Naik (1.4k1613) | answered Oct 19 '16, 5:34 a.m.
edited Oct 19 '16, 5:38 a.m.
 Hi Maria

We tried this with 6.0.2 and it worked well. The syntax is, the action should follow the work item number in the commit comment.
http://www.ibm.com/support/knowledgecenter/en/SS2L6K_6.0.2/com.ibm.team.connector.cq.doc/topics/t_git_actionable_comments.html

Example: workitem 11 time#4h, task 23 time#1w2d6h20m, defect 8 time#4h #resolve

Comments
Maria Victoria Martinez Torino commented Oct 19 '16, 1:54 p.m.

Thanks Shubjit for that useful link.

I had already tried those "Git actionable comments" and only the one that changes the status works for me.

Time is still not reflected in RTC....

Your answer


Register or to post your answer.