It's all about the answers!

Ask a question

.jazzignore file cannot be seen under Project & Package explorer views.

Ulhas Shetty (1316) | asked Jul 26 '16, 5:43 a.m.
edited Jul 26 '16, 12:49 p.m. by David Lafreniere (4.8k7)
Resources ignored and added under .jazzignore file which can be viewed under the project's loaded local folders but doesnt show up under Project or Package explorer views.
Checking in these components moved from Unresolved to Outgoing, but the Deliver option is not enabled. 

Can anyone help with this? On how to make these .jazzignore files view able and also to re-enable Deliver to higher stream so these .jazzignore files can be made available for others in the Project area.


Accepted answer

permanent link
David Lafreniere (4.8k7) | answered Jul 26 '16, 12:36 p.m.
Q: >> "but the Deliver option is not enabled."
A: Does your repository workspace have a flow target? The Deliver action will be disabled on change sets when there is no flow target. The context menu action of "Complete"

Q: >> "how to make these .jazzignore files view able"
A: By default, Eclipse will hide all resources that start with a period. You can change this behavior in the Package Explorer by clicking on the view menu ("down arrow" icon) and selecting "Filters...". From there, unselect the ".* resources" checkbox.
Michael Valenta selected this answer as the correct answer

Ulhas Shetty commented Aug 05 '16, 9:21 a.m.

Hi David.

Q1. I did have the flow target stream associated to my workspace but still couldnt see the Deliver option there.   
It did get corrected by itself and i could see the option for deliver later, guess the next day. Could be due to a restart.

Q2. I cleared the extensions under "Ignored resources" preferences option (my Eclipse versions doesnt have View > Filters.. option), but I dont see the .jazzignore files under packages.
Any idea what i would be missing?

Thanks for your help, David!

David Lafreniere commented Aug 05 '16, 3:53 p.m.

Re Q1: I'm glad it is working now.. I have never seen that before. Just to clarify though, you 'did' see the "Deliver" context menu action, it's just that it was disabled (greyed out) correct?

Re Q2: Sorry, the "Ignored resources" preference page is not what I'm referring to (which would explain why it is not showing). All versions of Eclipse have a view menu in the Package Explorer. See this post for an better explanation of where I am referring to:

Ulhas Shetty commented Aug 09 '16, 2:23 a.m.

 Q1. That's right. I could see the option, just that it was greyed out.

Q2. Thanks for the direction. I fixed the setting and I am able to see the ignored resources.

Thanks for your help!

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.