It's all about the answers!

Ask a question

RTC SVN integration appends SVN+ in SVN revisions making it inaccessible through web.


Rhishikesh Patil (1311227) | asked Jan 27 '16, 7:41 a.m.
Hi, 

We have CLM tools 5.0 and we have integrated RTC with SVN by following link https://jazz.net/help-dev/clm/topic/com.ibm.team.scm.svn.doc/topics/t_link_workitems.html 

This integration was performed by installing Subclipse 1.8.x on RTC 5.0 eclipse client.

Post integration when we checked RTC work item it had link to SVN revision. Nothing happens when you click this link. 
We have seen that this link has SVN+ at the start of actual link e.g. svn+https://myserver/svn/TEST_DEMO#6
When you remove SVN+ you can browse web version of SVN repository. 
Could you please answer below queries. 
Does this SVN+ triggers some client e.g. tortoise SVN? what all settings are to be done? or how can we restrict it from appending SVN+

Thanks in advance for your help. 
Regards, 
Rhishi



Comments
Don Yang commented Jan 27 '16, 7:56 p.m. | edited Jan 27 '16, 7:58 p.m.

It is a bit odd when clicking the SVN revision link, nothing happens. In our test before, it  jumped to History view and worked fine:


If there is any way to remove SVN+ , I'd love to know as well. My understanding is that RTC- SVC bridge only supports Eclipse client hence no other way to get Web client friendly URL.


Rhishikesh Patil commented Jan 27 '16, 11:50 p.m.

Thanks Don for your reply.

Yes RTC-SVN bridge seems to only support eclipse client and as pointed in your screenshot in RTC eclipse client when i tried to click SVN revisions it takes you to History view.

Be the first one to answer this question!


Register or to post your answer.