It's all about the answers!

Ask a question

An unhandled exception occurred during "Setup Project".


Sune Elvig (12) | asked Jan 11 '16, 7:12 a.m.
I am trying to initialize a new project. This is a new installation.  The server is running on IBM i. The database is running on IBM i.

 Problem
An unhandled exception occurred during "Setup Project".

CRJAZ0215E The following record was not found in the database: com.ibm.team.repository.common.model.impl.ContributorHandleImpl@731b9e1f (stateId: null, itemId: [UUID _YNh4MOlsEdq4xpiOKg5hvA], origin: <unset>, immutable: <unset>)

Reason
Initializes a project area with the pieces necessary to start work on a project.

We are using the 10 developer free license.

Please advise me what to investigate.

2 answers



permanent link
Chao Wang (225111) | answered Jan 11 '16, 8:54 a.m.
 Hi Sune,

What template are you using to create the project. Is it an Out of Box one(Scrum or Formal) or customized one? It seems you are trying to pull something that is not defined in the database. If it is a customized process template then take a look at the setup project section and see what is being performed for project initialization. You can try to remove some setup steps and then try and reinitialize the project.

Take a look at the link below for more information:

See example from scrum process:

Comments
Sune Elvig commented Jan 11 '16, 8:58 a.m.

  Hi Chao


I have tried both the Scrum and the Formal process template. They both fails. I have tried refreshing the templates multiple times, but the initialize still fails.  I will look at setup steps. Thank you.


permanent link
Alex Moore (811) | answered Jan 11 '16, 8:58 a.m.
JAZZ DEVELOPER
Hi Sune...

Being that this is a new setup I would delete the database since there's a problem with the databases.  Once you delete the databases go back through the jts/setup step again to regenerate the databases.

You can easily delete the database via the green screen.  If you used (ex. JAZZCCMDB) logon to the green screen and issue wrklib JAZZ* to display the libraries and 4=Delete.

Comments
Sune Elvig commented Jan 11 '16, 9:21 a.m.

 Hi Alex

Thank you for your answer. I will try that. That is maybe also the reason the variables are not resolved in the Process Template view.  I only see %scrum_spec_9, %scrum_spec1020 and %scrum_spec_40

I would like to upload a picture here, but my reputation is too low. 



Sune Elvig commented Jan 13 '16, 8:41 a.m.

Hi Alex


I am unsure about how to regenerate the databases.  Should I delete all  the JAZZ* libraries or only JAZZCCMDB? How can I regenerate the databases? I have tried deleting the JAZZJTSDB and the JAZZCCMDB but this makes it impossible to run the setup steps.

How should I proceed.

Br
Sune 

Your answer


Register or to post your answer.