It's all about the answers!

Ask a question

Importing a testcase and linking it to an existiing testsuite


Ursula Beiersdorf (133) | asked Nov 29 '15, 6:24 p.m.
Hi,
I am trying to import testcases via ecxelimport utility that are linked to existing testscripts AND to existing testsuites.
I managed to link the existing script to the testcase, but I failed with the testsuite.
Here is what I tried:

testcase.XLSStartRow=6
testcase.priority=A
testcase.dc:title=C
testcase.jzalm:owner=D
testcase.dc:description=E
testcase.Section("myns:com.ibm.rqm.planning.editor.section.testCasePreCondition","RQM-KEY-TC-PRE-COND-TITLE")=F
testcase.testscript=Link("urn:com.ibm.rqm:testscript:"&G) 
testcase.testsuite=Linkexisting("urn:com.ibm.rqm:testsuite:"&H)

but when I generate the XML file, there is no mention of the testsuite. The linking to the testscript works great.
What should I do?

Comments
Don Yang commented Nov 30 '15, 10:45 p.m.

what is ExcelImporter and RQM version?
is your test suite manually created on GUI or it was imported by ExcelImporter?

2 answers



permanent link
Reshma Ratnani (1.1k1) | answered Dec 01 '15, 12:29 a.m.
JAZZ DEVELOPER
Hi,

Did you try to export the excel directly to the server instead of generating the xml?
Does the linking show up when you use export to repository option

Comments
Ursula Beiersdorf commented Dec 01 '15, 4:29 a.m. | edited Jan 15 '16, 2:42 a.m.

Hi

I tried both, via export and import and via direct upload to the repository. Both do not work

I  am using the importer utility version 6 with a RTC in Version 5.0.1.

When generating the XML, I see that this line :testcase.testsuite=Linkexisting("urn:com.ibm.rqm:testsuite:"&H) is not transformed at all, no mention of a testsuite in the file.

The suite had been manually created.

Thanks for your help


Don Yang commented Dec 01 '15, 7:27 p.m.

I had tried v5.0.1 and 5.0.2 ExcelImporter with v5.0.1 RQM with no problem. In theory v6.0 Importer is not compatible with v5.0.1 RQM. you may want to try with v5.0.2 excelimporter given that your RQM is 5.0.1.
and you can check with one test suite such as testcase.testsuite=Linkexisting("urn:com.ibm.rqm:testsuite:xx")
xx is the test suite id and see if it works and then extend.


Ursula Beiersdorf commented Dec 02 '15, 3:20 a.m. | edited Jan 15 '16, 2:45 a.m.

HI Don,

thanks for your answer. I have tried all of the suggested: deinstall 6.0, install 5.0.2, and also I tried to exacly use one id for the suite as suggested by you. Still, no mention of the testsuite in the generated XML file.

my cfg file is by now:

testcase.dc:title=A
testcase.jzalm:owner=B
testcase.dc:description=C
testcase.Section("myns:com.ibm.rqm.planning.editor.section.testCasePreCondition","RQM-KEY-TC-PRE-COND-TITLE")=D
testcase.testscript=Link("urn:com.ibm.rqm:testscript:"&E)
testcase.priority=F
testcase.category term="Release".value=G
testcase.testsuite=Linkexisting("urn:com.ibm.rqm:testsuite:"&H)

And all works well except for the last row. If you say it works with you  - what exact cfg are you using?


Don Yang commented Dec 02 '15, 7:25 p.m.

I used sample TestSuite with TestCases 001.cfg
but comment out some lines for testing purpose

// this configuration file will create a static testsuite and a testcase object for each one listed
// and link all testcase to the testsuite


//testsuite.dc:title=C1
//testsuite.dc:description=A4
//testsuite.testplan=LinkExisting("urn:com.ibm.rqm:testplan:6")


//testcase.XLSStartRow=7
testcase.XLSArtifactID=B7
testcase.dc:title=B7
testcase.dc:description=E7
//testcase.jzalm:owner=C
//testcase.Section("myns:com.ibm.rqm.planning.editor.section.testCaseDesign","RQM-KEY-TC-DESIGN-TITLE")=F
//testcase.Section("myns:com.ibm.rqm.planning.editor.section.testCasePreCondition","RQM-KEY-TC-PRE-COND-TITLE")=K
//testcase.Section("myns:com.ibm.rqm.planning.editor.section.testCasePostCondition","RQM-KEY-TC-POST-COND-TITLE")=L
testcase.testsuite=Link(M7)

In M7, I have got something like: urn:com.ibm.rqm:testsuite:12


Ursula Beiersdorf commented Dec 03 '15, 4:46 a.m. | edited Jan 18 '16, 6:40 p.m.

HI Dan,

I also just tried the non changed version of the TestSuite with TestCases 001.cfg and actually it looks different to what you have above: it is meant to create a testsuite including testcases, testsuite.XLSLink=testcase, but not link to an existing.

When I try your approach, I see in the XML the standard HREF, same as for the link to the script... and it does not work when importing it into RQM. Which makes sense to me, as in case of script I link to a child, whereas for the suite, I link to a master.

Following this, it seems absolutely meaningful, when I try to create a new testsuite (as is in the above) I get another XML file for the testsuite, that then links the testcases to the suite. However, I did not find a place where to import the testsuite xml. - do you know where?

And also, it does not resolve my problem with the link to the existing suite.

Can you maybe post your complete cfg and all of the xml files that you import?


Ursula Beiersdorf commented Dec 03 '15, 3:44 p.m. | edited Jan 18 '16, 6:40 p.m.

HI,
I continued thinking myself :-) Obviously Ican try to import the testsutie when I export directly into the repository. But then I get an "Error sending to server <sheet name>.xml of type testsuite
The remote server returned an error: (500) Internal Server Error."
And in the log I find: ERROR: <Unknown Caller Context>: ExcelExportRepositoryDialog: Error saving to url
at com.ibm.rqm.oslc.service.internal.integration.handler.put.TestSuitePutHandler.createJSONSuiteStepsCommands(TestSuitePutHandler.java:561)

So you managed to import  (updates to)  testsuites? Because I only found reports in the forum where people had the same issue. If it worked at your side, which version do you have?
btw my config looks like this by now

testsuite.XLSLink=testcase
testsuite.XLSArtifactID ="urn:com.ibm.rqm:testsuite:"&B2
testcase.XLSStartRow=6
testcase.dc:title=A
testcase.jzalm:owner=B
testcase.dc:description=C
testcase.Section("myns:com.ibm.rqm.planning.editor.section.test
CasePreCondition","RQM-KEY-TC-PRE-COND-TITLE")=D
testcase.testscript=Link("urn:com.ibm.rqm:testscript:"&E)
testcase.priority=F
testcase.category term="Release".value=G


Don Yang commented Dec 03 '15, 6:02 p.m.

The cfg I posted is exactly what I tested with for my end user and it works for my RQM5.0.2+ExcelImporter5.0.2. I exported to RQM project directly. As you can see, I commented out testsuite creation part because I want to link the created test cases(from importer) to the existing test suite, hence using testcase.testsuite=LinkExisting(M7)
(my previous post testcase.testsuite=Link(M7) has a typo missing Existing). I just tested it again in my environment for a different project area and it works.

You may want to give it a try.


Ursula Beiersdorf commented Dec 07 '15, 10:35 a.m.

Hi, this worked, thank you!


Ursula Beiersdorf commented Dec 07 '15, 10:36 a.m.

This was the necessary hint! see below

showing 5 of 9 show 4 more comments

permanent link
Ursula Beiersdorf (133) | answered Dec 07 '15, 10:34 a.m.

HI Dan, thanks a lot for your help, your last answer helped me.

So for everybody else: it might be a problem with creating teststuites, but if you want to import testcases and link them to an existing testsuite, make sure to only include the inkexisting part and comment out the part with the testsuite reference. Also it is necessary to import via direct rqm import.

My complete and working CFG is then:

testcase.XLSStartRow=6

testcase.dc:title=A
testcase.jzalm:owner=B
testcase.dc:description=C
testcase.Section("myns:com.ibm.rqm.planning.editor.section.testCasePreCondition","RQM-KEY-TC-PRE-COND-TITLE")=D
testcase.testscript=Link("urn:com.ibm.rqm:testscript:"&E)
testcase.priority=F
testcase.category term="Release".value=G
testcase.category term="Regression".value=H
testcase.testsuite= Linkexisting("urn:com.ibm.rqm:testsuite:"&B2)

Your answer


Register or to post your answer.