It's all about the answers!

Ask a question

DNG 6.0 modifiedSince query through rest api is giving request timed out.


Shahnawaz Ul Haque (111) | asked Sep 15 '15, 3:42 a.m.
I am trying to get the data using DNG6.0 on Cloud through Rest API using the following query
https://jazz.net/sandbox02-rm/publish/resources?modifiedSince=2015-09-15T05:11:24.000Z&projectURI=_0Kld4VtQEeW38--RgA1WEw
Basically i want to get the data that was modified after 2015-09-15 - 05:11:24 (UTC). When i am trying to fetch data through this Uri nothing returns after i wait like 10-15 mins or so.

The result is when i post this rest Uri through PostMan(in Chrome) or RestClient (in Firefox), nothing returns in response. After a while i cancel the request.
So when i am doing the same from C# code i am getting request timed out. I tried to increase the timeout value but no luck in there. Somehow if the call doesn't contains any data then the response is returned successfully. But if it contains the details of some artifact(at least one) then its getting timed out..


What i am doing i am writing a notification service for Doors Next Gen 6.0 , the service after certain interval fetches records from DNG. And if some artifacts present in that response then i generate some notification through the details of the DNG Rest Response. The application used to work in DNG 5.0 but when i tried the same in Cloud it was getting error in authentication(OAuth) stages. After i cleared that i am stuck here. I also don't have an DNG 6.0 Cloud Documentation so to speak.

I need help regarding this or i am stuck for good. Any help is really appreciable.


Comments
Jayanta Patra commented Sep 16 '15, 9:25 a.m. | edited Sep 17 '15, 6:45 a.m.

I am also facing the same thing here.

I am using sandbox03-rm..
Any help here would be really helpfull.

One answer



permanent link
Donald Nong (14.4k213) | answered Sep 15 '15, 11:35 p.m.
It works for me - I just put the URL in Firefox (no need for RESTClient) and get an XML response. My sandbox is on "sandbox01-rm" so I am not sure it makes any differences. I also tried with your URL and got a 403 error, which is expected (at least it's not timeout).

Comments
Shahnawaz Ul Haque commented Sep 16 '15, 9:22 a.m.

 Howdy Donald..!!

 Thanks for your response..
I understand that this is working for you. But have you tried to retrieve artifacts through this query. I mean can you see actual records in the returned XML?
The URL i have mentioned, is working for me when there is no data. But if some valid data is there then it is getting timed out.!!

I just want to make sure that i am doing anything wrong here.!!

So could you confirm that. It'd be really helpful..!!


Donald Nong commented Sep 17 '15, 6:49 a.m.

Yes the actual artifacts are returned in the XML response, although I only have two requirement artifacts in my jazz.net sandbox.

Your answer


Register or to post your answer.