It's all about the answers!

Ask a question

How Do I Enable Verbose RRDG Logging in RDNG 5.0.2?


0
1
Nate Decker (37812958) | asked Sep 09 '15, 12:48 p.m.

In previous versions of Requirements Management (RM) (4.0.6), I would often rely on the log entries in the Rational Reporting Document Generation (RRDG) log to find out how I should be configuring my datasources in my Rational Publishing Engine (RPE) reports. For instance, when I launch a report in RM, I don't know what http request is issued under-the-hood and what XML response is returned by the server. It's different depending on whether the report is launched in the "quickprint" view, or the "collections" view, etc... In 4.0.6, I could look at the RRDG log file associated with the RM application and see the exact URL that was being used. I could copy/paste that URL into a browser and see the exact XML that is returned by the server.

In 5.0.2, when I look at the RRDG log, the data there is exceptionally sparse. There doesn't appear to be as much verbose logging of what RRDG is doing and the datasource URL in particular is markedly absent. Is there a setting somewhere that I can toggle in order to see the level of logging that I was used to in 4.0.6?

Accepted answer


permanent link
Donald Nong (14.4k314) | answered Sep 09 '15, 11:56 p.m.
The differences are in the <JAZZ_HOME>/server/conf/rm/log4j.properties file. The default setting in RDNG 4.0.6 is
log4j.logger.com.ibm.rational.rrdg=INFO, rrdg, stdout
In 5.0.2
log4j.logger.com.ibm.rational.rrdg=WARN, rrdg
You can change the setting by editing the file and restarting the server, or modifying it in /rm/admin without the need to restart the server.
Nate Decker selected this answer as the correct answer

Your answer


Register or to post your answer.