It's all about the answers!

Ask a question

Can you query for unassigned literal on a custom attribute?


0
1
Peter Kidwell (2389) | asked Jul 23 '15, 9:07 a.m.
In RTC 5, I put a custom attribute with a custom enumeration into my Story workitem type.  The new enumeration has an unassigned literal ("Unassessed") which is also the same as the default literal.  The attribute is required only at later stages of the workflow, but not initially.

We've added this new attribute late, and we have several stories already "in flight".  We tried to create a query to show us all the Stories that have the attribute set to "Unassessed".  Nothing came up, even when I could look at one particular story that is indeed Unassessed. 

Strangely, in the query builder, I don't have the "Unassigned" checkbox for this attribute, maybe because it is required at later points?  And I see the "exists" option for the attribute (in the same popup as "is" and "is not"), but there is no "not exists" option there.

How can we create this query?

2 answers



permanent link
Ralph Schoon (57.1k23642) | answered Jul 23 '15, 9:40 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I don't see an "unassigned" check box for any enumeration.

Because you have to specify a default attribute, an enumeration seems to be always assigned. I think the unassigned literal might just be there to be able to enforce a required value.

But the literal itself shows up as choice in the condition, so you can only select that and it should show the ones that have this value. I have never seen any difference between custom and built in enumeration type attributes.

Comments
Peter Kidwell commented Jul 23 '15, 9:45 a.m.

I do see the unassigned literal in the list of choices in the query builder, but when I select it, I get no results in the query.  I ran a query of all stories, without filtering by the new custom attribute, and simply displayed it in the results.  It shows as "-" for the ones I'm looking for, which seems like "null" or "empty" to me, but I have no way to filter on "null".


Ralph Schoon commented Jul 23 '15, 9:52 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This is what I see. There is no unassigned, but all the literals. Maybe we talk about different things?




Peter Kidwell commented Jul 23 '15, 9:57 a.m.

I see the same sort of thing.  The problem is that if I choose "Unassessed" (for my custom attribute, this is the equivalent of "Unclassified"), no results appear, even though I have several stories set to "Unassessed".


permanent link
K L (112) | answered Jul 23 '15, 3:22 p.m.
edited Jul 23 '15, 3:26 p.m.
I am not sure, but I would say that, as happened to us :
  1. You don't have the unassessed because the default value makes it impossible.
  2. Your existing Work Items don't have the default value because it was added after they were created.


If that is your problem, I suggest working in two steps :

  1. Remove the default value ; then you should be able to query the unassessed, and mass-modify your Work Items.
  2. Then restore the default value you want.

Your answer


Register or to post your answer.